Forums

OverviewFelgo 2 Support (Qt 5) › 2.16.0 Android fatal error on compile

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #19002

    Marcin

    Hi Felgo,
    Did anything change in regards of font handling?
    When compiling my game on Android(normal development) I am getting:

    :processDebugManifest UP-TO-DATE
    ERROR: In <declare-styleable> FontFamilyFont, unable to find attribute android:font
    ERROR: In <declare-styleable> FontFamilyFont, unable to find attribute android:fontStyle
    ERROR: In <declare-styleable> FontFamilyFont, unable to find attribute android:fontWeight
    
    :processDebugResources FAILED
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    Execution failed for task ':processDebugResources'.
    > com.android.ide.common.process.ProcessException: Failed to execute aapt

    I tried to remove some font loading which I use but didn’t fix it.
    I don’t want to spend an hour or so to find where is the issue.
    Maybe you have an idea?
    Maybe some SDK settings which I use?

    Can’t replicate it in other apps but the one with error is quite complex so hard to find the cause ad hoc.

    Ps. I use FontLoader in .otf format but I am not sure if it makes any difference.

    #19005

    Alex
    Felgo Team

    Hi Marcin,

    what platform are you building on?

    Also, what Android SDK version are you building against (Projects tab –> select Android kit –> Build Android APK)? And what target version is configured in your Android manifest file?

    And does this also happen when you try to deploy a new Felgo project?

    Cheers,
    Alex

    #19008

    Marcin

    Hi Alex,

    1. Platfrom: Linux Mint.
    2. NDK version: r14.
    Was working all the time fine but I am downloading now 10,since this is what Qt suggest as safe, right?
    3. SDK version 25.2.5
    4. Manifest
    Minim SDK version: 16
    Target SDK: 16
    5. Can’t replicate it with other projects, which were probably created much later so can have better setup for SDK.

    #19009

    Marcin

    I think I will copy the SDK settings from newer projects which compile, and see if it makes any difference.

    [Update]
    Unfortunately other projects have the same settings.

    #19010

    Marcin

    Can confirm the issues doesn’t happen when I compiled the same app on Mac.
    The difference is different SDK and NDK.
    On Mac I use SDK 26 and NDK 15c, will check the same settings on Linux and play a little with different combinations.

    #19012

    Yusuf Umut Piynar

    Hey, just uninstall the app from phone before building and some amateur thing but are you sure you are the admin when trying to use apt.

    #19013

    Marcin

    So problems solved?
    Yupi.
    Thanks all for help.

    It’s really weird.
    What I did was try multiple NDK (10, 14, 15) and just that didn’t fix it.
    I also switched to android-studio based folder for SDK, so android-studio manages that and installed 26.0.
    I cleaned build directory and now it works …
    So definitely NDK alone is not the issue, I can switch to 10 and it still works.
    Maybe Android SDK?
    Not sure, with 26 it works just fine.

    @Yusuf Umut Piynar
    I have enabled option during deployment of Android apps to always uninstall old version of the app before new deployment.
    If it works as intended, I should always deploy and install new version.
    But just to be 100%, I also manually deleted it once.
    Not sure if this just helped or this plus other cleanups/updates.

    PS. Maybe I will downgrade to 25 SDK at some point, but for now don’t have time to double check if this alone was the issue.

    #19037

    Günther
    Felgo Team

    Qt still suggests the usage of NDK r10e (since several versions). But I’ve also seen later NDK versions work just fine.

    In my experience, it is generally not 100% safe to switch SDK, NDK etc.. .immediately after a new version comes out (same for xCode / iOS). There’s no guarantee that a certain Qt version is already prepared to work with potential changes in latest native SDK tools.

    If you encounter issues, trying a different SDK or NDK version can definitely help. Also, a general rule for every Felgo or native SDK update is to clean your project and create a fresh build to make sure no previous artifacts mess with the new build somehow.

    Best,
    Günther

     

Viewing 8 posts - 1 through 8 (of 8 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support