Forums

OverviewFelgo 2 Support (Qt 5) › AppMap doesn't show user location

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #18991

    Ben

    Hello,

     

    I’m writing an app using the AppMap component but I can’t get it to work together with the location services on my phone. I tried both real deployment and via the Felgo Live app. I also tried it using a PositionSource but that one doesn’t work either.

    Here are the details about my environment:

    • Windows 7 with Felgo 2.16 (same problem with 2.15)
    • macOS Sierra with Felgo 2.15 (still need to upgrade)
    • iPhone 5S with iOS 11.3 (same problem with 10.2) and Felgo Live 2.16 (same problem with 2.15) and location services enabled

    Here are some settings and resulting values when running my app:

    • AppMap.enableUserPosition = true
    • AppMap.showUserPosition = true
    • AppMap.userPositionAvailable = false
    • PositionSource.valid = true
    • PositionSource.active = false (even though I explicitly set it to true)
    • PositionSource.sourceError = NoError
    • PositionSource.supportedPositioningMethods = AllPositioningMethods
    • ios/Project-Info.plist contains both NSLocationWhenInUseUsageDescription and NSLocationAlwaysAndWhenInUseUsageDescription
    • The iOS location services never list my deployed app as ever having requested access
    • The app never triggers the display of the location services arrow while opening Google Maps would. Everything works fine in the latter.

    Then I tried to test standard examples but none of them work:

    A final weird thing to note: The Felgo Live app is shown in the list of apps that requested location services but when I click on it, it only shows ‘Never (unchecked). If I then click on Never, go back and then click on Felgo Live again, it shows all three options. I then click ‘Always’. I have already reinstalled it.

     

    At this point I don’t know what to try next. Any help would be really appreciated.

    Thanks and regards,

     

    Ben

    #18994

    Alex
    Felgo Team

    Hi Ben,

    I can confirm that there seems to be an issue, thanks a lot for the detailed report. I will come back to you as soon as possible.

    Best,
    Alex

    #19069

    Ben

    Because I upgraded my phone to iOS 11.3 I was also required to upgrade Xcode and consequently macOS. So now I have macOS High Sierra 10.13.4 with Xcode 9.3 and Felgo 2.16. This allowed me to deploy the Maps example to my phone and that one finally worked.

    The next steps is now building on that example to see where my version is wrong. The Live Player still doesn’t work from Windows and I haven’t tried it from macOS yet.

    So I’m not out of the woods yet but there is progress.

    #19073

    Günther
    Felgo Team

    Hi Ben,

    glad to hear that you made progress!

    We’ve also tested some more. While custom projects seem to work fine with latest tool setup and v-play version, the Live Client app often shows issues with positioning permissions (similar to what you described). We’re working to get to the bottom of it, so next Felgo Live version hopefully won’t have this issue anymore.

    Best,
    Günther

Viewing 4 posts - 1 through 4 (of 4 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support