Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 1 Support › Build Error

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #5781


    Due to repeated issues while downloading v-play SDK I had to skip the Examples And Demos packages. I later updated them using the SDKMaintenanceTool.

    When I try to build any demo game I get the following errors


    :-1: warning: directory not found for option ‘-L/usr/local/pgsql/lib’

    :-1: warning: directory not found for option ‘-L/tmp/qt-stuff-85167/source/qt-everywhere-opensource-src-4.8.1/Desktop/Qt/4.8.1/gcc/lib’

    :-1: warning: directory not found for option ‘-F/tmp/qt-stuff-85167/source/qt-everywhere-opensource-src-4.8.1/Desktop/Qt/4.8.1/gcc/lib’

    :-1: error: symbol(s) not found for architecture x86_64

    :-1: error: collect2: ld returned 1 exit status




    Felgo Team


    can you give me the whole qmake output? Can you run a normal Qt-Quick project? What about an empty Felgo project?





    Hi Alex,


    I am not able to run am empty v-play project as well, same error but a project I created before SDKMaintenanceTool update works fine. Qt Quick project project also works.

    Qmake compile output

    14:19:14: Running build steps for project qmake…

    14:19:14: Starting: “/Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/bin/qmake” /Users/Pi/Documents/V-play/qmake/qmake.pro -r -spec macx-g++ CONFIG+=declarative_debug

    Project MESSAGE: Felgo SDK path: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK

    Project MESSAGE: Felgo target path: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK

    Project MESSAGE: Felgo library path: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK/lib

    Project MESSAGE: Felgo qml path: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK/qml

    Project MESSAGE: Felgo include path: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK/include

    Project MESSAGE: VPlayPluginsGenericPath: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK/plugins/generic

    Project MESSAGE: VPlayPluginsPlatformPath: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK/plugins/macx

    Project MESSAGE: QML_IMPORT_PATH: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK/qml /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK/plugins/macx /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/../../../FelgoSDK/plugins/generic

    WARNING: /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/mkspecs/features/v-play.prf:250: Unable to find file for inclusion /Users/Pi/FelgoSDK/Desktop/FelgoSDK/qmlapplicationviewer/vplayqmlapplicationviewer.pri

    /Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/mkspecs/features/v-play.prf:251: Unknown test function: qtcAddDeployment

    14:19:14: The process “/Users/Pi/FelgoSDK/Desktop/Qt/4.8.1/gcc/bin/qmake” exited normally.






    Felgo Team


    is there a folder /Users/Pi/FelgoSDK/Desktop/FelgoSDK/qmlapplicationviewer on your system? If there is, is there the file /Users/Pi/FelgoSDK/Desktop/FelgoSDK/qmlapplicationviewer/vplayqmlapplicationviewer.pri in there?

    If not, I can send you a link where you can download the files and copy it to the folder.

    Cheers, Chris



    Hi Chris,


    There is no  /Users/Pi/FelgoSDK/Desktop/FelgoSDK/qmlapplicationviewer folder.

    The problem seems to have gotten worse, I recently got a 4 week pro trial and when I used Package Manager to download the latest SDK and daily build I get this error: (this is when I have not selected any Examples and Demo package cause they always fail)

    Could not download archive: https://sdk.felgo.com/macx/qt/com.nokia.ndk.tools.desktop.481.gcc/4.8.1-1qt-4.8.1-desktop-gcc.7z :Connection closed


    The Qt Creator doesn’t run at all now. Can you please give me some direct link to the latest SDK. This problem has consistently bothering me from the day I started using v-play and is really slowing down the development process.


    Felgo Team


    could you please try to re-install only with the core packages enabled, by choosing the custom installation type and deselect everything except “SDK Core – MinGW”. So deselect “Examples & Demos”, “Documentation” and “Project Templates” and all packages of the Qt SDK. If that works, you can then download the remaining packages after the initial installation with the Felgo SDK Maintenance Tool.

    You can also download the packages and wizards from a link I’ll send you if the download with the Maintenance Tool again doesnt work.

    Please let me know if installing worked for you.

    Cheers, Chris



    I’ll give it another go but that is exactly what I did the first time around. Downloading the packages with the SDK Maintenance Tool is what broke things



    Felgo Team

    if you still experience problems with the online installer,please use this temporary solution:

    1. Download and install the Nokia QtSDK 1.2.1 for Mac (either the online or offline installer) from the Nokia website here (You need to register a Nokia account to be able to download it. Alternatively, you can download the online installer version from our server for Mac OS X here). If you already have the Nokia Qt SDK installed, you can skip this step.
    2. Copy the contents of this zipped file (230MB) to your Qt SDK directory. It contains the Felgo SDK version 1.5.0 with all its demos & examples, Qt Creator wizards and the offline documentation available in Qt Creator. To use the wizards when you create a new project, unpack the files from the folder <FelgoSDK>/Desktop/FelgoSDK/templates/ to .config/QtProject/qtcreator/templates/wizards/

    Please note, that you will not receive updates for Felgo with this solution, because the Felgo installer comes with an own version of the SDKMaintenanceTool explained here. But until there is an own offline installer for Felgo you can use it as a temp fix. I’ll keep you updated in this thread as soon as ther is a full Felgo offline installer.

    Cheers, Chris



    There seems to be some issue with the Nokia Qt SDK :

    Could not fetch Updates.xml from repository: http://nds2.fds-forum.nokia.com/nokiaqtsdkrepository/fremtiden/macx/10.6/online_qtsdk_repo. Error: Error downloading http://nds2.fds-forum.nokia.com/nokiaqtsdkrepository/fremtiden/macx/10.6/online_qtsdk_repo/Updates.xml?-1705465934 – server replied: Not Found.


    I downloaded the V-play SDK, I get the error

    :-1: error: The qmake command “/Users/david/FelgoSDK/Desktop/Qt/4.8.1/gcc/bin/qmake” was not found or is not executable.


    Obviously I don’t have the directory ‘david’ in my Users folder but I also don’t see a bin folder in /FelgoSDK/Desktop/Qt/4.8.1/gcc



    Okay I tried a fresh install another time and somehow it worked!

    Things are running fine, I ran an existing project and a problem I was having with Item rotation earlier got fixed as well!


    Do I dare try to update demo packages?


    Felgo Team

    That sounds good, as you are then able to update to the latest daily build as soon as we release it!

    As downloading went fine except for the demos, I would just copy the whole Felgo SDK to be sure to have a working backup if anything goes wrong at updating. You can then try to download the demos package. If it doesnt work, just paste back your backup and extract the examples, demos & wizards manually from the zipped Felgo SDK link above.

    Cheers, Chris

Viewing 12 posts - 1 through 12 (of 12 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded