Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 2 Support (Qt 5) › Can't build WebAssembly on Windows

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #23742

    Jean-Marc

    Hi,

    I’ve successfully followed the 3 first steps from:

    https://felgo.com/doc/felgo-deployment-web/#build-your-app-or-game

    (build on Windows) but at step #4 I’ve got this error:

    Project ERROR: Cannot run target compiler 'em++'. Output:
    ===================
    ===================
    Maybe you forgot to setup the environment?

     

    I’ve tried several things about this step but nothing works…

    Any clue or trick to help me ?

    #23744

    Alex
    Felgo Team

    Hi Jean-Marc,

    we recommend to use a UNIX-style command line also on Windows (like git bash), which has proven to work more reliable than the Windows command line. You will then also use the same commands as in the macOS/Linux step instead: https://felgo.com/doc/felgo-deployment-web/#build-on-macos-and-linux

    We will also update the guide with this recommendation soon.

    Best,
    Alex

    #23745

    Jean-Marc

    Thank you Alex, now it works! But…

    I’ve managed to build a test app, launch it on a local web server… the page display the Felgo logo with compiling… and after that the page is desperately blank!

    Any clue to investigate ? ^^

    Best,

    Jim

    #23746

    Jean-Marc

    Actually it runs!!!

    It was blank because I didn’t managed correctly the resource.qrc file in my project, so I fixed it and now my page runs perfectly in the browser.

    My little sample:

    http://applistudio.fr/wp-content/wasm/index.html

    Thank you Felgo, now I can add a new service for my clients with WebAssembly and the opportunities are big!!!

    Cheers,

    Jim

Viewing 4 posts - 1 through 4 (of 4 total)

RSS feed for this thread

You must be logged in to reply to this topic.