Forums

OverviewFelgo Plugins Support › Chartboost SDK

Viewing 11 posts - 16 through 26 (of 26 total)
  • Author
    Posts
  • #8346

    Mathias

    Yes, I’m using Chartboost plugin 1.04

    I’m using the chartboost.jar from github (243kb).

    • This reply was modified 4 years, 9 months ago by  maitek.
    #8358

    Mathias

    Okay, I tried today to build the application on a different system. I installed the complete developer environment again (Qt, Android SDK, NDK, JDK etc.), this time on Windows (before i used Mac). Since Alex said previously “we unfortunately can’t reproduce the issue with our test projects and the integration guide”, I was thinking maybe there is something wrong with my build environment.

    So after installing and updating everything I downloaded the chartboost demo from github and tried to deploy it on my Samsung S3 mini. I get the same error as I did on OS X:

    F/libc    (11868): Fatal signal 11 (SIGSEGV) at 0x006e0067 (code=1), thread 11929 (hartboostSample)
    "net.vplay.plugins.ChartboostSample" died.

     

    Does charboost work for you? I’ve tried everything but I cant get it to work.

     

    #8360

    Alex
    Felgo Team

    Just a short follow-up, we are currently testing Chartboost plugin version 1.1 which adds new functionality, fixes the known issues and also bumps the Chartboost SDK version numbers to the latest ones available. The update will follow during the week.

    Best,

    Alex

    #8361

    Mathias

    Awesome! Looking forward to it.

    #8462

    Jan

    Maybe I’m missing something bloody obvious, but I get the following debug output, when I run the ChartboostSample: “module “VPlay.plugins.chartboost” is not installed

    And I do have it installed.

     

    #8463

    Christian
    Felgo Team
    #8473

    Jan

    Yes, I tried it the Chartboostsample and the documentary way. And apart oft that I did not quite get if the bundle prefix is optional or mandatory for the Plugins to work…but as said: cant get the sample code to run either. Having a look at the qt installation folder i can see the chartboost libs…

    #8474

    Alex
    Felgo Team

    Hi,

    let’s try to get into the issue a little bit:

    1. Is the Chartboost import version matching the version you’ve actually installed (there is an update to version 1.1 available since the beginning of the week)? The latest plugin uses the import

    import VPlay.plugins.chartboost 1.1

    like in this demo file: https://github.com/vplayplugins/ChartboostSample/blob/master/main.qml

     

    2. Also, if you’re using Android, could you please make sure that you added the following line in your project file

    LIBS += -lChartboostPlugin

    like here: https://github.com/vplayplugins/ChartboostSample/blob/master/ChartboostSample.pro#L21

     

    3. Lastly, which platform are you building on (Android or iOS)?

     

    Thanks,

    Alex

    #8504

    Mathias

    I was successfully running the new Chartboost sample app on my android phone today. I had to install the Google Play Services via the Android SDK Manager as explained here. I then had to change the API level to android-21 in step 3 to match the API installed in the SDK Manager. In step 4 i edited the ChartboostSample/android/project.properties to also match the API level.

    Now it works and the problems I had before are gone. Next step will be to integrate the new Chartboost into my own game.

    #8505

    Christian
    Felgo Team

    Thanks for reporting Mathias!

    Cheers, Chris

    #8506

    Jan

    Thanks to your help it’s working for me as well, thanks!!!

Viewing 11 posts - 16 through 26 (of 26 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support