Forums

OverviewFelgo 2 Support (Qt 5) › error license when I run an application

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #15152

    Khungxahoi

    I got a problem about the license when i run an application that i built on Emty Application Felgo project . I didn’t use the funtion or component of V-play , i just use the funtion and component of Qt . It’s that a mistake ?? Help me, Please !

    The error report :

    ERROR: No LicenseValidator object found – do add a GameWindow and set the licenseKey property to use VPlay.

    #15153

    Günther
    Felgo Team

    Hi Khungxahoi!

    This is no error, just the normal behavior. A Felgo application expects the main Item of the application to be an App or GameWindow to be able to check for a valid Felgo license key. The problem should be gone once you add one of these components as the root item of the application.

    If you like to create a Qt application without Felgo, you can do so by opening the New Project Wizard in Qt Creator and selecting  Application > Qt Quick Application as the project type.

    Best,
    Günther

Viewing 2 posts - 1 through 2 (of 2 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support