OverviewFelgo 2 Support (Qt 5) › Installation Issues Felgo Qt 5

Viewing 15 posts - 61 through 75 (of 110 total)
  • Author
  • #10894


    deleted all things (Qt and V-play engine) from SDKMaintenanceTool then couldnt reinstall from it.

    After that I downloaded the Vplay installer again and installed first tools then start SDKMaintenanceTool and installed all things again

    and now kit problem solved but I have another problem.

    when I start BalloonPop on Felgo Sample Launcher, it works well however when I start a project on based BalloonPop project , the Balloon falls down ūüôā

    what is the problem ?


    28        PhysicsWorld {z:1; gravity.y:1; debugDrawVisible: false}

    changed the gravity to -1 and solved ūüėÄ

    • This reply was modified 4 years, 8 months ago by  beginner.

    Felgo Team


    oh bummer, you are right, we didn’t update the wizards accordingly to the update of our physics engine. Thanks a lot for bringing this up, we will fix it with the next update of Felgo. In the meantime, you can use the source code from the examples instead of the wizards.

    Best Regards,


    Miguel Angel García Lucanu

    Hello there!

    I’m on KaOS 2016.01, and downloaded the Felgo 64-bit installer. I’ve installed it, but it did not run the Sample Launcher.

    Also, I can’t open the QtCreator nor the Sample Launcher from their paths. I’ve executed them from Konsole, with the following result: “QCoreApplication::arguments: Please instantiate the QApplication object first”.

    [EDIT] Also, when I try to launch QtCreator from its bin path (~/FelgoSDK/Tools/QtCreator/bin/), it shows:

    static QPlatformTheme* QKdeTheme::createKdeTheme(): Unable to determine KDE dirs 
    Segmentation fault (core dumped)


    Therefore I can’t even use it. Any tips?



    Felgo Team

    Hi Miguel!

    It is a known issue that the 64 bit SampleLauncher from the SDK is currently broken, you can download the working standalone version here.


    As for Qt Creator:

    I just set up a fresh KaOS installation and tried installing Felgo.¬†Qt Creator works fine and I was able to build and run Felgo projects as expected. (both when starting¬†Qt Creator from bin via console¬†or normally).¬†When running Qt Creator from bin I also get¬†the “Unable to determine KDE dirs” message, which doesn’t seem to be a problem. I guess the main issue in your case is the Segmentation fault.

    You can also try installing the latest Qt version from and see if the official qt distribution and Qt Creator works. If you get the same error there, the problem is not Felgo related but a general Qt problem with your setup. Maybe someone in the official Qt forums can help you out in this case.



    • This reply was modified 4 years, 3 months ago by  GT.
    • This reply was modified 4 years, 3 months ago by  GT.
    • This reply was modified 4 years, 3 months ago by  GT.
    • This reply was modified 4 years, 3 months ago by  GT.

    Miguel Angel García Lucanu

    Hi, G√ľnther, thanks so much for your quick reply.

    About the Sample Launcher, the one you provided works flawlessly, no issues so far.

    About Qt Creator, I installed the latest from KaOS repositories, and it works fine. Can I use this one then, instead of the Qt Creator offered with the Felgo installed?

    Many thanks, I hope I can start building something. I have high expectations ūüėÄ


    Felgo Team

    Happy to hear the SampleLauncher works ūüėČ

    Does the Qt version from KaOS also allow to manually add packages with the Qt MaintenanceTool?
    It is possible to add Felgo to your existing Qt installation, so maybe that works then. See here: Add Felgo to existing Qt installation
    This way, you would also get a clean Qt installation including Felgo.


    Alternatively you can also try to manually add build-targets in your Qt Creator, that refer to the Qt-version of the separate Felgo installation, which also include the Felgo libraries.





    There is an error while adding new tools to Felgo.

    the error

    Is it important thing ?



    I chose “ignore”.


    • This reply was modified 4 years, 1 month ago by  beginner.


    Felgo User

    Hi everyone

    I am having few issues with VPlay.

    I have already Qt(version 5.5.1 Android) and Qt creator(ver 3.5.1), so I just added repository and do all necessary procedure to add but after installation it shows following error.

    Could not resolve dependency ‘Core(3.6.0)’
    Could not resolve dependency ‘ProjectExplorer(3.6.0)’
    Could not resolve dependency ‘Help(3.6.0)’


    How can resolve this please suggest, I am stuck and unable to deliver the project..


    Hope revert soon with resolution.


    Felgo Team


    Felgo currently works with Qt 5.6 and Qt Creator 3.6 and also adds a few customization for Qt Creator (I guess the errors show up after starting Qt Creator?).
    The Felgo lib might still work with Qt 5.5 anyways Рare you able to create, build and run Felgo Projects? (e.g. with the wizards New Project -> Felgo Games -> Empty Felgo Project).

    To get rid of all the issues, please update your Qt version or simply use the Felgo installer to install Qt and Felgo together.




    what does the following error mean?


    error: VPApplication: No such file or directory

    #include <VPApplication>




    I wanted to create an android app. So downloaded and installed the packages which are necessary. After that I am getting this error. I’ve been using v-play framework for quite a few days, but never encountered¬†with this error.

    Please suggest me.


    Felgo Team

    Hi Santosh,

    The error indicates that the Felgo library is missing for the Android Qt Kit you are using for building.
    Did you install the latest Felgo version 2.9.0 with our installer?

    Felgo 2.9.0 switched to Qt 5.7, if you update to Felgo 2.9.0 or do a reinstall with the current installer, the Qt 5.7 Kits for Desktop and Android should contain all required Felgo libraries. Please note that during the update the Felgo library is removed from the previous Qt 5.6 Kits, so they can no longer be used to build Felgo projects.





    I installed : qt-opensource-windows-x86-msvc2015-5.7.0.exe
    by using :MaintenanceTool.exe I installed V-play 2.9.1
    again I updated my Qt Creator 4.1.0 by MaintenanceTool.exe


    But Now When I start Qt It shows me :

    The Following Plugins have Errors and can not be loaded:



    Could not resolve dependency ‘Core(4.0.3)’
    Could not resolve dependency ‘ProjectExplorer(4.0.3)’
    Could not resolve dependency ‘Help(4.0.3)’



    Felgo Team

    HI Mafhoom!

    Felgo also installs a custom Qt Creator Plugin for Qt Creator 4.0.1. Our Felgo installers correctly install Qt Creator 4.0.1 with the plugin.
    However, the current Qt installer already uses Qt Creator 4.1.0, which is not compatible with our plugin that targets 4.0.1.

    If you install Felgo with Qt 5.7 and Qt Creator 4.0.1 using the Felgo installer provided on our homepage the issue should be gone.
    Is there a reason why you do not use our installers?






    In the last few weeks, I tried to use V-play. I have installed V-play successfully but I have some problems for compiling a sample.

    In the¬†last steps of compiling, compiler starts downloading some stuff¬†from ‚Äú‚ÄĚ . My question is what this stuff is and why this stuff should¬†be gotten at¬†compiling time? can I get them before compile and put them in a desired path?

    my internet connection speed is very slow and I ‚Äėm still waiting to¬†finish downloading.

    I really need some helps.



Viewing 15 posts - 61 through 75 (of 110 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
create apps
create games
cross platform
native performance
3rd party services
game network
level editor
easiest to learn
biggest time saving
best support