Forums

OverviewFelgo Plugins Support › Local notification plugin – duplicated notifications in the notification area

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #15415

    Marcin

    Hi all,
    I am testing now local notification plugin a lot and can observer another weird behaviour.
    Despite the issue I am describing, the most important issue is this one: https://felgo.com/developers/forums/t/vplay-plugin-dem-crash-on-android

    Ok, this one is really confusing, behaviour depends on Felgo libraries version and Android version.

     

    First scenario.
    Felgo plugins demo application in Google Play.
    1. Android 6.0.1, Samsung S6
    When notification is fired and the application is in foreground.
    Getting “Felgo Plugins has stopped” error, but the app still works, looks like.
    Getting still the notification in notification area despite the application was in foreground.

    When application is in background, always getting double notifications.
    If application was in background but still running, on clicking getting “Felgo plugins has stopped” error but the app works.

    2. Android 4.1.2 Samsung S3.
    No duplicated issues and no “Felgo Plugins has stopped” errors.

     

    Second scenario, newest Felgo stack.
    It is opposite to the Felgo plugin app, what means no duplicated issues in Samsung S6, but duplications and “Felgo plugins has stopped” in Android on Samsung S3.

    In general, there are at least 2-3 issues in the newest Felgo stack.
    Also maybe would be a good idea to update more often the plugin demo app in Google Play because it doesn’t reflect current Felgo engine behaviour.

    Best regards,
    Marcin

    #15436

    Alex
    Felgo Team

    Thank you for the summary Marcin, there is already a ticket that we’re working on internally, we can give you a short update soon!

    Best,

    Alex from Felgo

    #15438

    Lorenz

    Hi Marcin,

    We just released a potential fix for these issues. It should be applied automatically by the Gradle Build System with your next build.

    You can validate that Gradle correctly downloaded the fix by running “./gradlew dependencies” from the command line within the build-xyz/android-build directory and having a look at the “net.vplay.plugins:plugin-notification” line that should state version “2.9.2-1”.

    The fix is not yet included in the Plugin Demo on the App Store. Thus, please use our version on GitHub.

    Please let me know if it works now!

    Cheers,

    Lorenz

    #15501

    Marcin

    Hi Alex, Lorenz

    Tested the changes and used 2.9.1.

     

    marcin@laptop ~/W/g/b/android-build> ./gradlew dependencies | grep noti
     \--- net.vplay.plugins:plugin-notification:2.+ -> 2.9.2-1

     

     

    Short version

    1. No more duplications and no more, no fatal, “Felgo plugins has stopped” errors. No notifications when app in foregrond.
    2. The issue when the app crashes when app was not working while clicking notifications- still exists(https://felgo.com/developers/forums/t/vplay-plugin-dem-crash-on-android).
    3. I am not able to run your gihub example- when try to run on Android get “can not start the application”

    Long version

    1. Tested both older and newer Android devices. Always get only one notification and never when app was in foreground. Had no problems to run it in some simple example(new created project). But had few issues with my main app which was created some time ago. Had to upgrade gradle(gradle.build file) from 1.1.x to 2.1.0. Also was missing this line “defaultConfig.applicaitonId = ‘my.app'”. Without this one the plugin didn’t work at all(no errors just did nothing).
    2. Still app crashes if notification is clicked while the app was not running at all.  Both devices the same.
    3. In the example project from github I have changed the app id in config.json, manifest.xml and apple project file. Then I generated new license key. No problems on desktop. Running on Android doesn’t work.

    Best regards,
    Marcin

     

    #15519

    Lorenz

    Hi Marcin,

    I am not able to run your gihub example- when try to run on Android get “can not start the application”

    Did you uninstall the Felgo Plugin Demo from the app store before trying to deploy? Both apps have the same package name, but are signed with different keys and thus it might not be able to replace it.

    I am currently looking into the remaining issues and will come back to you asap.

    Best,

    Lorenz

    #15525

    Marcin

    Hi Lorenz,
    Got the github example working.
    We are talking all the time about https://github.com/Felgo/PluginDemo, right?
    Ok.
    1.
    Gradle version issue, but the info how to change gradle-wrapper is clear so after doing this, all ok.
    2.
    License key.
    Obviously just generating key, like in the docs in Readme.md, won’t work(net.vplay is restricted, can’t generate keys for this) 🙂
    We need to change the app id in order to get new app key.
    To change the app name(app id) need to change 5 places: config.json, android/AndoidManigest.xml, ios/Project-Info.plist, android/build.gradle and android/google-services.json.
    Now you can generate the key for the app id you created.
    3.
    Had one issue with the fact that, for any reason, QtCreator didn’t create valid PluginDemo.pro.user so compiledSdkVersion in gradle was 1, invalid.
    But next time when I opened freshly cloned git repo and checked Android kit, that file was there.

    After that, application works ok.
    Still it crashes, but everything else works: the fixes you did.

    I propose strongly to update that Readme.md file 🙂

    Best regards,
    Marcin

    #15526

    Marcin
    #15531

    Lorenz

    Hi Marcin,

    Thanks for the input! We will update the Github example indeed.

    We just pushed a fixed version to our Maven repository. Now all problems should be sorted.

    Please test it and let me know if you still experience any issues.

    Cheers,

    Lorenz

    #15533

    Marcin

    Hi Lorenz,

    Got the update, 2.9.2-3.
    Tested using my standard older and newer Android.
    All main 3 scenarios, app in foreground, app in background and app not started when receiving notification.

    Tested using your PluginDemo and one of my old games.
    In all 3 cases had no issues whatsoever, no duplicates, no crashes, everything works.

    Great !

    I hope I won’t bother you with this plugin for a long time 🙂

    PS. I don’t yet deploy anything to iPhone, but will soon. Fingers crossed.

    Thanks
    Marcin

    #15536

    Lorenz

    I’m glad everything works now 🙂
    Well, if you experience any problems with iOS, you know where to get support 😉

    Cheers,

    Lorenz

Viewing 10 posts - 1 through 10 (of 10 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support