OverviewFelgo 1 Support › Problem with FontLoader

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #4511



    I got an issue with the FontLoader. I tried to use one global fontloader for each text in the game. This worked perfectly fine on the PC and on “slower” devices like the HTC One S, but when I tried to start it on my Nexus 4 and on a friends Galaxy Note, it chrashed. So I tried multiple fontloaders in each qml-file, a text was used…same outcome.

    Now I tried a lot of different stuff, and I finally got the app to start on my Nexus 4. The one thing that did it was to remove the fontloader in our MenuButton, which gets created about 45 times.

    So my question, is this a known issue with v-play, that an app force closes on a faster smartphone, when a fontloader is used too often and can I do anything against it?



    Felgo Team


    as a rule of thumb you should only use one FontLoader item for each custom font in your game. This is indeed not a known issue atm, could you probably tell us which font(s) are you trying to use and against which version of Felgo SDK you are building currently?





    I thought so too, but when one fontloader didn’t work, I tried multiple. But cause this didn’t work either, I went back to the version, where I just got one fontloader in the main.qml. But as I said, now I use the custom font everywhere except for the 45 buttons, in order to have a version in the google play store that starts without crashing on each device.

    I’m using the most up-to-date version of v-play, i think it’s 1.3.

    And the font I am using is galascript.ttf (Gala Script) and I also tried it with chalkduster.ttf (Chalkduster). But I gotta say it seems like the font itself is not the issue here.


    Felgo Team


    just tried a plenty of custom buttons with galascript.ttf font on a Nexus 7 and unfortunately could not reproduce your crash. Is it possible to send us the apk (via email) which crashed on your devices to be able to further debug the problem?

    Thanks a lot,




    Oh sry, I forgot to mention, that I also tried it on my Nexus 7 and there it worked, which disagrees with my assumption that this problem occurs with all fast devices. So I’m not sure what exactly the problem is, but as a matter of fact it doesn’t work on a Nexus 4 or a Galaxy Note 2, whereas it’s no problem on a Galaxy S or a HTC One S (and the Nexus 7).

    I’ll send an email with the apk at



    Felgo Team

    Great thx, please keep us updated if a new build actually solved your problem!





    Solved it…thx! 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
create apps
create games
cross platform
native performance
3rd party services
game network
level editor
easiest to learn
biggest time saving
best support