Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 2 Support (Qt 5) › QDOC does not create HTML files

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #16133

    Alexander

    Hi!

     

    I am trying to use “qdoc” for my project – however not for documenting my but instead just purely to create a tutorial about it. So I studied the qdoc-manual and tried out some simple things. However I was not able to produce actual HTML files out of it.

    I created a separate folder where everything following is stored.

    My .qdocconf file:

    
    outputdir   = ./html
    
    sourcedirs  = ./sources
    
    exampledirs = ./examples
    
    imagedirs = ./images
    
    outputformats = HTML

    And inside the the setup source directy (./sources), I placed a .qdoc file:

    /*!
    	\page test-tutorial.html tutorial
    	
    	\title Test Tutorial
    	
    	\brief BLLLLAAAAAA
    	
    	TEST TEXT TO FIND OUT
    	if this stuff works as intended.
    */

    And to create the HTML I open a CMD and navigate to the folder where the qdocconf file is located and execute:

    C:\SOMEPATH\tutorial>D:\Programming\FelgoSDK\5.8\mingw53_32\bin\qdoc test.qdocconf

    This does create “html” folder, containing an “images” folder and “.index” file BUT nothing else. Since there are also no errors printed on the CMD, I am not really sure what the problem is, since everything seems valid.

     

    Thx in advance for the help!

    #16140

    Günther
    Felgo Team

    Hi Alexander!

    Can you try also setting the file-extension of your sources that QDOC should parse? For example:

    sources.fileextensions  = *.qdoc
    

    Best,
    Günther

    #16141

    Alexander

    HI!

     

    Thx for the reply! Adding this line did the trick. I am just surprised since in QDOC manual, it is stated that .qdoc files are among the ones, which are recognized by default.

     

    Best

    Alexander

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.