Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 3 Support (Qt 5) › QT 5.6 and Vplay 2.8 Issues

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #12850


    Recently upgraded my project to QT 5.6 with VPlay 2.8. My project seems to be having issues with navigation stack, listmodels, and messagedialogs now. This project was fully functional under QT 5.5 and the previous version of VPlay. I downgraded QT down back to 5.5 and want to do the same with VPlay but when set up to build with Qt 5.5, VPApplication cannot be found for inclusion in main.cpp:

    #include <VPApplication>

    Is there anyway to set VPlay to compile properly with QT 5.5 again and revert to the previous VPlay version? I’ve tried a fresh install of QT and VPlay with only 5.5 selected and it seems like VPlay doesn’t compile with QT 5.5 anymore. Can I point QT 5.5 to the library location of VPlay? Any advice in the right direction would be helpful.


    Thank you


    Felgo Team

    Hi Jared!

    What issues do you have with the NavigationStack or Dialogs?
    With Felgo 2.8 we did some changes to the NavigationStack, they still remain even when you downgrade to Qt 5.5.

    See the changelog for more information on 2.8.
    The NavigationStack issues most probably come from these changes, like renamed method names for better understanding, e.g. popAll() -> popAllExceptFirst().
    Also the splitView feature is now deactivated by default, so when you want to use splitView you should set the property manually to splitView: tablet.

    I recommend to update your project to match these changes, as you are then also compatible for future Felgo releases.





    Good evening Günther,


    I updated my project as I’m on a deadline and couldn’t afford the wait. Using the message example in VPlay for reference I had to place the navigation stack into a wrapper page and create the pages as separate pages before it would work. Previously I was using the .push() and .pop() methods. Once I put it in the wrapper it starter working. I also moved to the new methods you mentioned.


    The dialogs now all show “Invalid Property” warning on everything that isn’t the id. This still function perfectly fine, but it certainly makes a mess of the code readability.


    While I’ve got your attention, the update seems to have thrown a wrench in my listModel as well. I know this isn’t specific to VPlay and it’s probably part of the upgrade to QT 5.6, but it’s throwing “Unknown Reference” errors when I try to display the information in a delegate. I’m able to print the model data with a


    And it prints the information, but when I call it within the component delegate, it says “temp is not defined.”


    Text {
      text: (kilnstatus =="true"|| kilnstatus=="Execute") ?   temp:"N/A";
      anchors.right: parent.right
      anchors.rightMargin: parent.width*.01
      font.pointSize: 26
      font.bold: true

    Here is the call in the delegate and below is how I set the listmodel temp value:

    listModel.append({"name" : network.list[i][0], "status" : network.list[i][4], "connection" : network.list[i][3], "temp" : network.list[i][2], "schedule" : network.list[i][5], "step" : network.list[i][6], "holdtime" : network.list[i][9], "elapsedtime" : network.list[i][10], "ramprate" : network.list[i][7], "setpoint" : network.list[i][8], "uid": network.list[i][1]});


    I can access every other property I defined in this statement without a problem. Any ideas?


    Thank you,



    Felgo Team

    Did you try renaming the “temp” property to something else? If all other properties work it might be worth a try.

    For the Dialog issues: I don’t seem to have this problem (e.g. with the Dialogs in the Component Showcase appdemo), maybe a clean and fresh reinstall of Felgo can help?

    Concerning going back to Qt 5.5 I’ll follow up with you via email.


    • This reply was modified 8 years, 4 months ago by  GT.


    Yes, I have tried renaming “temp” several times to different names with no luck. I’ll keep hammering on it and hopefully find an answer somewhere.


    I’ve reinstalled VPlay and QT I think a total of 6 times over the past 24 hours and it seems to happen every time. Again, it’s not affecting actual run time, but it is there in the code, see the attached screenshot: http://bit.ly/1pHHWwa


    I’ll be waiting for the email. Thank you again!


Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded