Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › QZXing linker error on linux desktop

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #24392

    Paweł

    Hello, in my application i have used QR code scanner, using QZXing library (https://github.com/ftylitak/qzxing ). I embed the source code in my project adding 

    include(QZXing/QZXing.pri)

    to my .pro file. When compile for Android platform everything works fine, but when i switch to Felgo desktop i get linker error, that I paste below:

    /usr/bin/ld: /home/user/Felgo/Felgo/gcc_64/lib/libFelgo.a(spinemeshrenderer.o): undefined reference to symbol ‘glEnable’

    /usr/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/9/../../../x86_64-linux-gnu/libGL.so: error adding symbols: DSO missing from command line

    In .pro file I have:

    QT += svg widgets positioning location multimedia
    CONFIG += qzxing_multimedia
    CONFIG += felgo
    CONFIG += c++14

    And in section linux!:android I have:

    linux:!android  {
        LIBS += -lGL -lssl -lcrypto
    }

    Thanks for your help.

    #24394

    Alex
    Felgo Team

    Hi,

    You might miss some more OpenGL dependencies, can you try to modify your LIBS line to:

    LIBS += -lGL -lGLU -lGLEW -lglut -lssl -lcrypto

    Best,
    Alex from Felgo

    #24399

    Paweł

    I added dependencies to GLEW and freeglut, previusly installed with apt but still get the same linker error. Before I added QZXing to project everything works fine on Desktop but now I can only run application on Android.

    #24424

    Alex
    Felgo Team

    Hi,

    We just tested the project on Ubuntu 18.04 and it compiles & runs fine. Which Linux distro are you using?

    Thanks,
    Alex from Felgo

    #24425

    Paweł

    I am using Ubuntu 20.04.2 LTS

    #24435

    Gregor
    Felgo Team

    Hello @Pawel,
    I made a fresh Ubuntu 20.04 VM and tried to reproduce your issue. However it worked fine and I couldn’t reproduce the issue.
    Beside Felgo SDK, installed these packages:

     sudo apt-get install g++ libglu1-mesa-dev libpulse-dev libglib2.0-dev \
                          build-essential git  libssl-dev qt5-default

     

    Then Created new Felgo application with wizard, cloned the library, updated pro and added scan example from the library documentation.
    https://postimg.cc/jCQS18Pp

    PS: Also tried with Ubuntu 18.04, also no problem there.

     

    gregor from Felgo

Viewing 6 posts - 1 through 6 (of 6 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded