Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Type AppTabButton unavailable

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #18350

    Marek

    Hi

    After last update I have this error when starting app on Android.

     qrc:/qml/pages/SettingsPage.qml:37 Type AppTabButton unavailable
     qrc:///qml/VPlayApps/controls/quick2/AppTabButton.qml:48 Cannot override FINAL property

    This is 2.15.0 version with Qt 5.10.0

    Small work around is:

    import QtQuick.Controls 2.2 as QControls
    
    QControls.TabButton {
    
    }

    But it does not apply style/theme like with AppTabButton

    Best Regards

    Marek

    #18351

    Alex
    Felgo Team

    Hi Marek,

    can you provide a minimum code example that shows the issue? Also does it only happen on Android and is there a difference between using standard deployment and running it with Felgo Live reloading?

    I just tried this code example (from the doc) and it worked in all cases:

    import Felgo 3.0
    import QtQuick 2.4
    
    App {
      NavigationStack {
        Page {
          AppTabBar {
            id: appTabBar
            showIcon: true
    
            // we use a custom colored rectangle as the tab icon
            Component {
              id: colorRectangleIcon
              Rectangle {
                property string tabText: parent && parent.tabButton && parent.tabButton.text || ""
                anchors.centerIn: parent
                width: dp(Theme.tabBar.iconSize)
                height: width
                color: parent.selected ? tabText.toLowerCase() : Theme.tabBar.subTabTitleOffColor
              }
            }
    
            AppTabButton {
              text: "Red"
              iconComponent: colorRectangleIcon
            }
            AppTabButton {
              text: "Green"
              iconComponent: colorRectangleIcon
            }
          }
        }
      }
    }
    

    Cheers,
    Alex

    #18353

    Marek

    Hi

    Ok, I know the problem already, it is specific to only my installation. I will describe this via email.

    Best Regards

    Marek

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded