Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 3 Support (Qt 5) › Achievements not display correctly in GameNetworkView

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #10861




    I have a problem with the GameNetworkView.

    Once an Achievement is unlockedthe name gets invisible and it show 1Points instead of the configured points.


    How can I fix this?


    And can I somehow change the background color of the GameNetworkView?


    Here is the code of my Scene:


    SceneBase {
      id: leaderBoardScene
      property alias view: myGameNetworkView
      VPlayGameNetworkView {
        anchors.fill: parent.gameWindowAnchorItem
        id: myGameNetworkView
        gameNetworkItem: gameNetwork
        showLeaderboardsHeaderIcon : false
        bodyColor: "#FF9800"
        bodyLightColor: "#FF9800"
        separatorColor: "#009688"
        tintColor: "#FF9800"
        tintLightColor: "#FF9800"
        onBackClicked: {
              window.state = "menu"
      }// VPlayGameNetworkView







    Ok, after more testing the achievement system seems completly broken to me.

    When an achievement gets unlocked subsequent calls to


    lead to subsequent calls of


    which means my Unchaviement unlocked overlay gets shown multiple times.

    Another point: some of my Achievements get unlocked in Groups.

    I have three achievement for starting the app. One with target 10, one with target 50 and one with 100.

    All of them got unlocked when the target 10 was reached even though all of them have different keys?!

    Is there some way to completly reset the achievement data? I have the feeling that something is going terrible wrong here.


    If you need some information about my code feel free to ask.




    Felgo Team

    Hi Mailerdaimon!

    The behavior you describe really is a bit odd. I just tried a simple example with grouped achievements and different target values.
    I did not experience any of your problems. Are using the latest Felgo SDK version? (Though as far as I know, we didn’t change the game network in our last updates).

    To get rid of your previous achievement data you can do the following:

    • Try setting new achievement keys for your achievements, which should lead to the creation of completely new achievements to avoid potential mix-ups.
    • Also, you can delete your current game in the GameNetwork backend and create a new one. You can then use the new gameId and a totally fresh game network.

    One additional tip: When using game opener achievements, it might be best to add them to the onCompleted handler of the VPlayGameNetwork component, as described here.

    I hope this helps! If you still experience the same problems, please provide some more information on your usage of the game network and your log output.

    PS: If you want to fully customize the UI, you can implement you own GameNetworkView, there are already some forum posts about this.


    • This reply was modified 8 years, 5 months ago by  GT.


    Hi GT,


    thank for your reply. I finally solved the issue by doing:

    • a reset of all local data
    • build and run in “test” phase
    • delete the game in the backend and create a new one

    All is running fine now even though I do not know which of this steps really helped as I did it all at once.





    Felgo Team

    Hi Martin!

    Good to hear that it works now!
    My guess is, that the creation of the new game in the backend did the trick. 😉


Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded