Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › After 2 months CreateGame is throwing error of authentication failure.

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #24250

    Taher

    Hello,

    I have created game using multiplayer component, I have generated app key secret and it was all working as expected.

    After generating keys and secret for about 2 months the game was not used and there was no request made. After 2 months when i’m trying to call the createGame method it returns below error:

    Socket closed: 3 1000

    qml: Master: Disconnected

    qml: : Connecting to Game wss://GCAMS087.exitgames.com:19091

    qml: Game: PhotonPeer[_dispatchPeerStatus] – No handler for connecting registered.

    qml: : State: JoinedLobby -> ConnectingToGameserver

    qml: Game: Connected

    qml: Game: Authenticate…

    qml: : State: ConnectingToGameserver -> Error

    qml: : Error: 2101 Game authentication failed: 32767 Non token authentication is not allowed

    qml: : Error 2101: Game authentication failed: 32767 Non token authentication is not allowed

    qml: Socket Error: 4 The remote host closed the connection 1000

    qml: Game: Server closed connection

    qml: : State: Error -> Error

    qml: : Error: 1003 Game server closed connection

    qml: : Error 1003: Game server closed connection

    qml: Socket closed: 3 1000″

     

    Notice that in 2 months there are no code changes has been made. Wanted to understand what is the expiration time limit for app key and license and what should be the next expected step to make it working again?

    #24261

    Alex
    Felgo Team

    Hi Taher,

    please send your game id from the gamenetwork dashboard to support@felgo.com so we can look into that. Such keys usually do not expire.

    Please also try setting those properties on your FelgoGameNetwork item in your code once, to see if any cached settings are an issue:

    clearOfflineSendingQueueAtStartup: true
    clearAllUserDataAtStartup: true

    Best,
    Alex

    #24282

    Taher

    Hello Alex,

    The 2 properties you suggested that is already set to true and the problem is not in startup. The problem occurred when i try to create room.

     

    Also i have tried to contact to the support team using the mail id you suggested, but there is no reply yet. We are blocked by this issue and waiting for the reply from many days. Please direct us with some solution which can be tried out.

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded