Forums

OverviewFelgo 2 Support (Qt 5) › After publish Felgo Live does not recognize file changes

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #18374

    Arne

    Hi,

    the changes of my files are not recognized by the Felgo Live Server/Client anymore.

    I updated to the latest version of Qt Creator 4.5.0, Felgo 2.15.0 and I am working on macOS Sierra 10.12.6. Everything worked as expected until I followed the tutorial for publishing. I tried to change back to the previous file settings for stage “test”. Also the changes in main.cpp and .pro file.

    I can start the app in the Felgo Live client and it runs without errors, except that lokal file changes are not recognized.

    Then I tried to create a blank new project with the project wizard. With that the local file changes are recognized in Felgo Live. I compared all files but there are no differences except that I load the plugins for admob and onesignal. Also there is no difference if I comment out the plugins.

    Is there a Felgo Live Server Cache or something like that?

    Greetings, Arne

    #18381

    Alex
    Felgo Team

    Hi Arne,

    the Live Client stores the project files locally in its cache, however not in a way that would prevent changes from being ignored. Does the client reload after a change but displays the old source code, or does it not react to file changes at all?

    Cheers,
    Alex

    #18386

    Arne

    Hi Alex,

    the client does not react to file changes at all!

    I have to restart the client to see the changes.

    #18389

    Marcin

    Hi all,
    Sorry for off-topic.
    I experienced similar behavior just didn’t have time yet to analyze it better.
    Have already opened issue on forum.
    For me the problem started after git branch switch.
    Won’t span here anymore, just wanted to confirm that it’s not an isolated issue.

    #18390

    Arne

    If that helps, I am using a git repository too.

    #18398

    Alex
    Felgo Team
    #18488

    Arne

    Hi,

    I can not confirm that it is the same problem as of Marcin.

    I created a new project, copied only the qml and asset folder over to the new project, without git integration and added only “QT += webengine” to the .pro file.

    The active kit is “Felgo Desktop (Qt 5.10.0 clang)”. It compiles and runs without errors in the live server debug console.

    But it still does not recognizes the qml file changes in Felgo live. I have to restart the Felgo live server to get the changes recognized.

     

    #18502

    Arne

    A second ago I deleted a file by QtCreator, a dialog pops up if I want to push this change to git as well. If I click yes, QtC commits AND the running Felgo Live instance reloads! .. So I would say, the problem with all of this relies on something with git. 😉

    #18522

    Alex
    Felgo Team

    Hi Arne,

    yeah we also suspected this in the thread with Marcin. We plan to change the way the file watcher picks up changes, to also be able to detect the way git changes the files.

    Thank you a lot for the reports.

    Cheers,
    Alex

Viewing 9 posts - 1 through 9 (of 9 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support