Forums

OverviewFelgo 2 Support (Qt 5) › Always get trial watermark on firebase plugin and cannot make it function

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #17127

    paul grant

    Hi,

    I trying to enable the Firebase plugin.

    I’ve purchased Indie license solely to get access to these plugins!

     

    I’ve tried to see them working by using the Plugin demo, but always get watermark saying its a trial version!

    I’ve:

    1. generated the key for firebase, google analytics and GCM
    2. Uncommented the library in the gradle file of the demo
    3. Ive generated a new google-services.json for my firebase project

    What else needs to be done?

    I’ve also tried with my own app following the instructions for adding a plugin, still always see
    trial watermark!?!

     

    Do I need to install a license in the build system?

     

    Can you help!

    BR

    Paul Grant

     

     

    #17137

    Günther
    Felgo Team

    Hi Paul,

    there is no additional license setting required. The application and all chosen plugins are fully available by

     

    Please also make sure to set the app identifier and version settings for your app to match the license key configuration (see here). You should immediately see a difference when running the project after adding the license key (also when running the project on Desktop):

    • Is the Felgo Splash Screen gone?
    • Is the watermark gone? (Note: The watermark will also show if a plugin is used somewhere, which was not activated when creating the license key)

     

    To avoid possible issues with previous builds that didn’t use the license, please make sure to create a fresh build:

    • Delete any previous version of the app from your test device
    • Remove the build directory from your file system
    • Right-click the project in Qt Creator and choose “Clean”, followed by right-click and “Run qmake”
    • Rebuild and run the project.

    Do you see any difference when running the licensed app with a fresh build?

    Best,
    Günther from Felgo

    #17142

    paul grant

    HI,

     

    When I follow the above instructions, the addition of license key does remove the

    watermark, however I get the following errors/warnings:

    Plugin not supported!

     

    If I move to an Android device (sony 4.4.4 tablet), I no longer get the plugin not supported message, but I
    get the following errors in the debug pane:
    Local module descriptor class for com.google.firebase.auth not found.
    and ‘An issue occurred’ popup, which says the :
    email address is badly formatted

     

    Looking at the manifest permissions, I noticed that no internet access was granted:
    So I added permissions for ACCESS_NETWORK_STATE,  ACCESS_WIFI_STATE, INTERNET etc

     

    Can you help, as I’m on a up against it on timescale!

    BR
    PAUL GRANT

    #17145

    Günther
    Felgo Team

    Hi Paul!

    The removed watermarks is a good sign – the plugin activation issue is solved then.

    Regarding the “email address badly formatted” issue:
    Can you send your reference firebase demo project that shows the issue to support@felgo.com?

    We will have a look as soon as possible!

    Best,
    Günther Teufl

    #17146

    paul grant

    Hi Gunther,

    Please find attached my example.

    Its the reference code created from the wizard for firebase plugin project creation, with

    websockets client added to test network connectivity is working!

    here’s a link to the project code:

    https://github.com/readysteadygo2006/fb-test

    BR

    Paul Grant

     

     

    #17151

    Günther
    Felgo Team

    Hi Paul,

    we’ve had a look at the project that you shared and did some testing:

    • ​The message “Local module descriptor class for com.google.firebase.auth not found.” can be ignored.
      ​We’ve confirmed that Firebase Auth & Realtime Database work perfectly fine despite this initial message. The same applies for other related exceptions in the log that can also be ignored, e.g.:
      E FirebaseApp: Firebase API initialization failure.
      E FirebaseApp: java.lang.reflect.InvocationTargetException ….
    • The popup about email address is badly formatted that you see is returned from the login/register call to Firebase.
      ​The popup dialog is triggered after the error was returned, see FirebaseLoginPage.qml at onUserRegistered or onLoggedIn.
      ​I was able to successfully register a test user guenther.teufl@felgo.com, you probably did not enter a valid email address for login.

    In my opinion the plugin is already working fine for you, please make sure to provide correct credentials for login / register with Firebase Auth.

    Best,
    ​Günther from Felgo

    #17173

    paul grant

    Hi Gunther,

    Following up on the firebase plugin issue. As you suggested the plugin was already working,
    I was not seeing this, because the account on Firebase I was trying to login to, was created
    using google authentication. via the firebase web api.

    My question now are:

    1. Does the plugin support authentication google, facebook etc, or only via
      email/password?
    2. Additionally is there anyway of turning on debug on the plugin’s which would give some sort of
      trace so that you can certain they are doing something

    BR

    Paul Grant

     

    #17181

    Günther
    Felgo Team

    Hi Paul,

    at the moment we support the Firebase database and authentication via the email/password authentication provider. The plugin is quite new and these are the main features that we started with.

    It is possible to let your users log-in via Facebook using the Facebook Plugin. The plugin works standalone though, so you won’t be automatically logged into Firebase in this case. We have more Firebase features on the Roadmap of course – are there other features except e.g. Google Authentication that you are interested in?

    About Debug Output:
    Felgo internal debug logs are not available when using the plugin. However, it is usually sufficient to check your log for error messages, which are always printed in case the plugin runs into some trouble.

    Best,
    Günther

     

Viewing 8 posts - 1 through 8 (of 8 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support