Forums

OverviewFelgo 2 Support (Qt 5) › Android build SDK not defined and Not add android virtual device

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #17125

    Felgo User
    #17133

    Günther
    Felgo Team

    Hi!

    Which Android SDK / NDK version are you using?

    Qt often has compatibility issues when new version of e.g. Android NDK/SDK (Android) or XCode (iOS) are released.
    Based on known issues, we at the moment recommend to go with Android SDK 25 and Android NDK r10e.

    After changing the Android settings, please make sure to re-configure your Android settings for your project:

    • Close Qt Creator
    • Delete the shadow build directory (e.g. build-<project>-Android_for_armeabi_v7a-….) from your file system
    • Delete the *.pro.user file from your project folder
    • Open the project and reconfigure your Kits
    • Rebuild the project

    Are you able to build for Android after making sure you are using a compatible version of the tools?

    Best,
    Günther

     

Viewing 2 posts - 1 through 2 (of 2 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support