Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Android Deployment

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #8284

    Nour
    #8285

    Christian
    Felgo Team

    Hi,

    from the docs about Publish Builds:

    To enable a Publish Build, set "stage": "publish" in your config.json file in the qml folder and build a Release Build from Qt Creator.

    Cheers, Chris

    #8286

    Nour

    Hi Chris

    I did this before..

    there warning when i run app on device “missing config.json”

    i dont know if this related

     

    this is my file

    {
    “title”: “Dominoes”,
    “identifier”: “com.maysalward.Dominoes”,
    “orientation”: “landscape”,
    “versioncode”: 2000004,
    “versionname”: “3.3”,
    “stage”: “publish”
    }

     

    #8287

    Christian
    Felgo Team

    Hi,

    can you try to create a new Empty Felgo Project from the wizard, and then set the stage to publish in the config.json file. The devBuild text should then be invisible.

    Cheers, Chris

    #8288

    Nour

    Hi

    I am stuck now with Felgo icon in addition to that text

    may i can send a sample of the code

     

    Thanks

    #8771

    Nour

    Hi

     

    The problem raise again, i tried to edit .pro file and  have it like this

     

    #allowstoaddDEPLOYMENTFOLDERSandlinkstotheFelgolibraryandQtCreatorauto-completion

    TEMPLATE=app
    CONFIG+=v-play
    QT+=qmlquick
    
    
    qmlFolder.source=qml
    #DEPLOYMENTFOLDERS+=qmlFolder#commentforpublishing
    
    
    assetsFolder.source=assets
    DEPLOYMENTFOLDERS+=assetsFolder
    
    
    #Addmorefolderstoshipwiththeapplicationhere
    
    
    RESOURCES+=\
    resources.qrc#uncommentforpublishing
    and edited main.cpp but the text is still shown
    please help
    
    
    thanks
    #8772

    Christian
    Felgo Team

    Hi,

    I just tried it as well, and it worked fine – the text is not displayed when setting the stage to publish (both when I enabled resources, and also with the default deploymentfolders settings).

    Can you try if the text is shown when you create a new Empty Felgo Project? (both when enabling deploymentfolders, and also resources)

    Cheers, Chris

    #8779

    Nour

    I am not able to go with publish build on new project

    This error shown on console

    W/Qt (18299): (null):0 ((null)): [System]- [WARNING]: System can’t parse stringData file “{

    W/Qt (18299): “title”: “Untitled1”,

    W/Qt (18299): “identifier”: “com.maysalward.tarneeb”,

    W/Qt (18299): “orientation”: “landscape”,

    W/Qt (18299): “versioncode”: 5,

    W/Qt (18299): “sdk”: “daily”,

    W/Qt (18299): “versionname”: “3.0”,

    W/Qt (18299): “stage”: “publish”

    W/Qt (18299): }”

    #8782

    Christian
    Felgo Team

    Can you please send the project to support@felgo.com ?

    Cheers, Chris

    • This reply was modified 6 years, 6 months ago by  Christian.
Viewing 9 posts - 1 through 9 (of 9 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded