Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 1 Support › Android – strange issue

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #4345


    Our game builds on Mac OS and for Android too, we can install it (Nexus 7 Tablet) but it lacks a bit in performance.

    That’s not the major thing, we’ll find this problem, the real strange thing is that sometimes (e.g. on state change) a dialog appears.


    Get data from file(assets/) failed!


    What is causing this issue and how can we fix it?

    Thanks in advance.



    Felgo Team

    Hi Peter,

    please have a close look at the debug output of the desktop version at first: go to the “Application Output” pane and press Ctrl + F and search for “error” and “warning”. Maybe you will find your error on desktop as well. Is this message exactly what your application pops up? Do you visually see any problem with your game, like missing images, fonts, etc.?

    Next step would be, to inspect the Android debug log output. You can do that by installing the Android SDK and then call ddms from the android-sdk/tools folder. Then look through the Android log for errors and warnings and nail your issue down. If the error is not in your code, please send us your log output so we can have a look at it.

    Cheers, Chris


    Felgo Team

    I know this problem – it’s that on Android, and apparently only on Android, file names are case sensitive.

    Be careful that you always use files with the same cases as they are in the project – best solution is to always use lower case file names and folder names.



    The problem was that we had an ImageView that had no source initially set, because at startup its invisible anyway. Just adding a source to the invisible view solved the problem. I guess on Android he did not found the image with no name 😉



    Unfortunately we now have another strange bug that only appears from time to time. When our game is finished it sometimes is possible that our menu buttons do not work anymore. We do however never modify any of those buttons in any other way than visbility.

    Have you any ideas why this could happen?


    EDIT: We just experienced this bug under iOS but we are not able to find it.



    We also solved this one! Solution for all if you are experiencing the same.

    If you have a MultiTouchArea element that gets disabled in certain moments it can be that it still has the focus. This means that a MouseArea cannot react to clicks in this state and the whole game blocks.

    Solution: Also make the buttons a MultiTouchArea!


    Felgo Team

    Thanks for the hint, we’ll check if we can fix that in the element itself!


Viewing 7 posts - 1 through 7 (of 7 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded