Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 1 Support › App icon not shown on android device

Tagged: ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7262

    Mathias

    Hey.

    I have been trying to create an app icon for my game by following instructions here. I have added app_icon.png (250×250 png file) to the qml folder, before uploading it to the build server. My icon is correctly shown next to the binary in the build server interface after uploading, but when downloading the apk to my device the default v-play icon is still shown instead of mine.
    What might I be doing wrong?

    – Mathias

    #7263

    Christian
    Felgo Team

    Hi Mathias,

    on which device are you testing your app?

    Could it be that an old version of your app was installed before, and your  phone’s launcher doesn’t update the icon?

    You could try uninstalling the app before installing the new version or deploy on another device (or the Android emulator).

     

    If this is not the problem, I will try to investigate further.

     

    Cheers,

    Chrisu

    #7264

    Mathias

    Hi Chrisu.

    I have tried to uninstall the app before installing the new version. I also tried to restart the device. I guess what you are saying is that the icon is cached somewhere in my device.  Im using a samsung galaxy s3 mini.

    • This reply was modified 6 years, 7 months ago by  maitek.
    #7266

    Christian
    Felgo Team

    Hi again,

    another thing that might cause problems with the app icon are 8-bit PNG files. If you use an 8-bit PNG please try reformatting it to 24-bit (for example in the save options of photoshop/paint.net).

     

    Cheers,

    Chrisu

    #7269

    Mathias

    It seems like the 8-bit png was the problem. I exported the icon in 24-bit and now it works.

    Thanks.

    • This reply was modified 6 years, 7 months ago by  maitek.
Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.