Forums

OverviewFelgo 2 Support (Qt 5) › AppStore publish linking issue

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #19111

    Marcin

    Hi Felgo,
    After upgrade to 2.16.0, I can’t deploy app to AppStore.
    I am not sure if this upgrade is the issue though, maybe it’s just a coincidence and the issue is somewhere else.

    During archiving I am getting:

    ld: could not reparse object file in bitcode bundle: 'Invalid bitcode version (Producer: '902.0.39.1_0' Reader: '900.0.39.2_0')', 
    using libLTO version 'LLVM version 9.0.0, (clang-900.0.39.2)' for architecture arm64
    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    After standard googling it can be few things.
    1. There can be some mismatch between some XCode version and libraries.
    I have the newest Xcode available and there are no more updates, so guess is not this one.
    2. The libraries were built with different version and I try to link against different version?
    I am not sure if I fully understand how this works.
    But the reason I am concerned is other people were reporting that they were using some libraries which didn’t want to work with Xcode they use.
    Can it be that one of the Felgo libraries used in ios need rebuilding?
    No idea.
    3. Of course the workaround is to disable bitcode.
    Didn’t try it yet but some reports show that this doesn’t always solve the issue.

    Like I said, with previous version of Felgo I was able to publish my app.
    Now I can’t and the main thing that happened in between was the Felgo upgrade.
    I am not saying that is the main issue but this is my first candidate after I applied all Xcode updates.
    Any hints?

     

    PS. I tried all standard solutions, so delete shadow build directory, clean project in QtCreator and Xcode.
    Open IDEs after the cleanup etc.
    Maybe I miss something here but I am not sure what else can I do.

    #19114

    Marcin

    Can confirm that disabling bitcode solves this issue.
    Of course I don’t want to release the game without bitcode support, so this is just temporary.

    #19120

    Alex
    Felgo Team

    Hi Marcin,

    We are not aware of any bitcode issues, and just uploaded another app yesterday without any issues. Are you using Xcode 9.3? Are you using any Felgo Plugins? If yes, which ones?

    Thanks,

    Alex

    #19121

    Marcin

    Hi Alex,
    Thank you for answer.
    Of course, basic data: XCode 9.3, plugins all apart from 3 for push notifications(only local), no Amplitutde, no Facebook, no GameCenter.

      VPLAY_PLUGINS += admob
        VPLAY_PLUGINS += chartboost
        VPLAY_PLUGINS += soomla
        VPLAY_PLUGINS += flurry
        VPLAY_PLUGINS += hockeyapp

    If it’s nothing you’re aware of will do some more digging.

    #19122

    Marcin

    Did more tests.
    App created with xcode natively, can archive no problem.
    Very simple app(no plugins, basic template) created with Felgo, which I published before, can’t archive anymore, the same error.
    My game with no plugins enabled, the same error.
    Funny thing, the very simple Felgo app, I didn’t rebuild it, it was the same code built with previous Felgo version.
    Means some xcode config in the end plus library which ss built with different version than I use?
    Probably it’s my setup which is somewhere not up to date.

    #19124

    Felgo User

    Hi,

    I have the same problem. I have updated all VPlay components and now I have the same issue when trying to archive product in Xcode

     

    ld: could not reparse object file in bitcode bundle: ‘Invalid bitcode version (Producer: ‘902.0.39.1_0’ Reader: ‘900.0.39.2_0′)’, using libLTO version ‘LLVM version 9.0.0, (clang-900.0.39.2)’ for architecture arm64

    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    #19127

    Alex
    Felgo Team

    Hi,

    We are currently doing some testing with different build setups and let you know as soon as possible what might be going wrong.

    Thanks,

    Alex from Felgo

    #19129

    Alex
    Felgo Team

    Hi,

    Just a short follow up, can you please let us know the Xcode version number you have installed on your system (menu item “Xcode” -> “About Xcode”)? And which macOS version are you using?

    Xcode version

    Latest Felgo libraries are built with Xcode 9.3 as stated above, as Marcin correctly pointed out, the error usually pops up if you’re using an older version of Xcode on your system. Despite an update, disabling bitcode should fix the issue right away.

    Many thanks,
    Alex from Felgo

    #19131

    Marcin

    Don’ have access to my Mac at the moment, will the check the version later.

    Have another theory.
    Don’t have time yet to check this but … this can be xcode in the end.
    My situation:
    1. I don’t want to upgrade to HighSierra(yet), so using one version of MacOS before, just Sierra, I think.
    2. There is a new version of xcode but only for HighSIerra so system doesn’t say there is an upgrade available.
    3. BUT there is still an update for xcode but sitting between my current version and the newest for HighSierra.
    4. Once I manually went to updates, find xcode I can see an update, not to the newest version(HighSIerra only)but newer than I have. Will finish the upgrade today in the evening and maybe that will fix it.
    5. Bottom line, this can be issue with MacOS not sending notification about new xcode if you’re not on High Sierra(at least in my situation).

    #19132

    Alex
    Felgo Team

    That’s also one of our ideas at the moment! If it turns out that the latest Sierra Xcode is not Bitcode-compatible with the latest High-Sierra, we can for sure provide alternative Felgo libraries for you guys. From the log output you provided it looks like your system is still on a 9.0 version, that’s why I just wanted to double check the build number (9E145) with you.

    Thanks,

    Alex

    #19135

    Marcin

    Ok, in the end I gave up an upgraded to High Sierra and Xcode 9.3, and it fixes the issue.

    I was wrong that I was on 9.3, it was all the time 9.2.
    Was confused because release notes were pointing to 9.3, and I got no official notification about new upgrades, so thought I am on the newest version.
    Looks like Xcode 9.2(9C40b) bitcode is not compatible with newer versions(9.3 9E145).

    #19138

    Alex
    Felgo Team

    Thanks for the info Marcin. Bitcode versions are for sure not compatible then, we will pay closer attention to possible compatibility issues in the future. Usually you should always be fine with the latest versions provided by Apple.

    Best,

    Alex from Felgo

Viewing 12 posts - 1 through 12 (of 12 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support