Forums

OverviewFelgo Installation › Can not run on android

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #17260

    Bryan

    Hello, read multiple posts on this site and others, nothing seems to fix this…

     

    MacOS Sierra v 10.12.6
    Qt Creator 4.4.1
    Qt 5.9.2

    installed qt
    Setup Android
    Installed v-play
    All android kits are suddenly missing
    V-play apps do run on desktop (app playground)
    Manage devices, clicked ok
    Settings > Devices > Android – re-choose the JDK, SDK, and NDK locations
    Closed Qt Creator
    Opened Qt Creator
    Android Kits are back
    So are iOS kits (Did not configure them)
    Re-opened app playground
    Configured for both Desktop and Android x86
    None of the QML files appear in the project
    When attempting to build –
    “QApplication not found” is issued by the compiler.
    “VPApplication not found” is issued by the compiler.

    Attempting to create any qt or v-play application from the new project wizard yields the same results

    Completely removed Qt and v-play

    Installed just v-play
    Desktop works
    Android kits are missing
    Close everything
    Ran maintence tool – installed android

    MacOS Sierra v 10.12.6
    Qt Creator 4.4.0
    Qt 5.9.1

    Opened the app play ground, QML files are displaying again, tried to build…

    Error
    Android build SDK not defined. Check Android settings.
    Error while building/deploying project AppPlayground (kit: Android for x86 (GCC 4.9, Qt 5.9.0 for Android x86))
    When executing step “Build Android APK”

    Downloaded, installed and configured Android NDK 10e
    Same error
    Restarted qt creator, its locking up and won’t display a project

    Verified the following are installed:
    Android 8.0 API 26
    Android 7.1.1 API 25
    Android 7.0 API 24
    Android 6.0 API 23

    created a new project
    same error
    Desktop builds
    Android complains about missing SDK

    Removed all SDKs and re-installed Android 7.1.1 API 25
    Closed qt creator and restarted it
    Created another blank v-play application
    Desktop builds
    Android complains about missing SDK (both debug and release)

    https://forum.qt.io/topic/83476/android-build-sdk-not-defined-check-android-settings-qt-5-9-1-qtcreator-4-4-0-with-android-studio/13

    In the build steps the build SDK is blank
    Download and installed the SDK Build Tools

    Closed qt creator and restarted it
    Created another blank v-play application
    Desktop builds
    Android complains about missing SDK (both debug and release)

     

    I realize this might be a bug in qt creator itself, I will keep trying but I cant build anything for droid.

    #17261

    Bryan

    Confirmed a  work around:

     

    Open the pro.user file and replace

    <value type=”QString” key=”BuildTargetSdk”></value>

    with

    <value type=”QString” key=”BuildTargetSdk”>android-26</value>

    does work, its was not ideal

    I am posting this in these on this thread in case someone else stumbled in with the same issue.

     

    This saga began with an error “QApplication not found”

    it was not obvious to me (just running the installer) that I had to run the maintenance tool, and as for the work around, it wont be obvious to most new users where v-play ends and qt-creator begins.

     

    #17262

    Christian
    Felgo Team

    Hi Bryan,

    thanks for sharing the workaround!

     

    The current state of Android deployment is not ideal, as there are issues with Qt Creator 4.4.0 and certain Android SDK/NDK version combinations.

    To improve this state, we’ll release a Felgo update next week that will add support for Qt Creator 4.4.1, which should fix most of the issues you described. This update will then also be based on Qt 5.9.2.

    The preferred way to use Felgo is by using our installer and not the Qt installer. Main reason is that if you install Felgo for Android with a Qt installation, you first need to select the currently supported Qt version by Felgo, with Felgo 2.13.1 that is Qt 5.9.0 (5.9.1 had major issue on iOS thus we skipped that version) – and then install Felgo with it. If you use the Felgo installer, it just works as the correct dependency is used.

     

    To further improve the mobile deployment process, we will release of the QML Live Reloading apps for iOS & Android very soon. Stay tuned. 😉

     

    Cheers, Chris

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support