Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 3 Support (Qt 5) › Cannot mix incompatible Qt library error – after system(Ubuntu) upgrade

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #14145


    I upgraded my system, from very old (12.x) to 15.x(vivid) version.
    Since I use Kubuntu it uses heavily it’s own Qt version.
    As long as I am aware that is not an issue since QtCreator configuration for QtVersion and kit point to internal Felgo version.
    Anyway, after the upgrade, all V-play projects(old and completely new from templates) fail with:

    Cannot mix incompatible Qt library (version 0x50401) with this library (version 0x50600)

    Weird thing though, with the same QtVersion and kit settings, other(no Felgo) examples from QtCreator, work just fine.
    Looks like it mixes 5.4(probably in my old system?) with 5.6.
    I re downloaded all Felgo package and deleted QtCreator config in ~/.config/… directory.
    Apart from loosing all configuration I still get this error.

    Currently I use Qt 5.6(maintenance tool) because of 3D bits which I don’t see in 5.7, so didn’t download it yet.
    I can see two auto detected QtVersions in QtCreator settings, both pointing to Felgo, not the system one.
    Not sure what to do.
    Any suggestions?


    Felgo Team

    Hi Marcin!

    We also use Qt 5.6 as the base for Felgo (switch to 5.7 will come soon, probably this week).
    I agree that it sounds like something gets mixed up (maybe a Qt dependency/module that is used in Felgo is linked to your system Qt 5.4 instead of Felgo Qt 5.6?).

    If you open up  <v-play-sdk-dir>/5.6/<compiler>/mkspecs/features/v-play.prf you can see the dependencies and includes that a Felgo project automatically configures/links to the project. Maybe this can help you to figure out which setting causes the error? (because it seems Qt projects without these settings work).




    Thank you Günther for suggestion.
    In the end, it was just my system.
    It turns out that it was either not lucky upgrade process or the fact that first version of KDE5 has some issues.
    After upgrade to newest 16.x Ubuntu with much more stable KDE5, everything is fine.

    Probably using KDE in Ubuntu is just not the best idea, will switch in the future to something else where KDE is more maintained.

    PS. I couldn’t find anything in the v-play.prf file that would indicate that QtCreator uses system libraries.


    Felgo Team

    Hi Marcin,

    happy to hear that it works now – have fun developing then!


Viewing 4 posts - 1 through 4 (of 4 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded