Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Cannot using HttpRequest / XMLHTTPREQUEST on android – qml: SSL handshake failed

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #23096

    Bancha Rajainthong

    I have developed a parcel tracking app with Felgo using HttpRequest to get data from RestAPI.

    Everythings work fine during development on Windows10.

    But the application does not work on Android device (android 9) or Android emulator (x86).

    I also try to build the app with Openssl lib from this repo https://github.com/KDAB/android_openssl

    But not working. Not sure what happen just saw the “qml: SSL handshake failed”  in debug output

    Which seems to be related to OpenSSL.

    I am using Felgo 3, Qt 5.13.2 Android SDK 26 and NDK 21

     

    I also check the OpenSSL is supported and running with below version

    Compile with: OpenSSL 1.1.1b 26 Feb 2019

    Running with: OpenSSL 1.1.1c 28 May 2019

     

    https://dl3.pushbulletusercontent.com/VVXIh6kbpROr3mZq9HPdxl6YTLO3j7Ee/2020-03-21%2016_50_01-AfterPost.pro%20@%20AfterPost%20-%20Qt%20Creator.png

    https://lh3.googleusercontent.com/a7hTl-I_wzFwV8ayV0KowwCs7Sqpo_JptxSKwit3wdY3jcoW7iHg3IZYRFHQD380TEyVC2nlioAsb9ZSzx9zKmpbPg=s341

     

    #23098

    Bancha Rajainthong

    After searching for a couple of days I think the problem may come from Android runtime permission.

    The “SSL handshake failed” is hinted me to the wrong clue.

    #23624

    Felgo User

    @Bancha,

    Do you mind sharing what’s your discovery?

    I am running into the same problem for android target after upgrade server to https.

    IOS works, wasm works.

    thanks,

     

    Jun

    #23627

    Alex
    Felgo Team

    Hi,

    can you share the uses-permission and uses-feature tags that your generated AndroidManifest.xml contains? You can find it at <path to your build folder>/android-build/

    Are you using any native device features like camera, location etc?

    Best,
    Alex

    #23628

    Alex
    Felgo Team
    #23629

    Felgo User

    Thanks Alex for looking into this.

    The demo model does work for me.

    So my guess, the problem might be on server side.

    Our server side is using Node.js with https. the SSL cert is issued by zerossl, very standards settings.

    IOS, and web access are all fine. so still puzzled here, why handshake failed.

    Below is permission and features as your request.

    Please help and advise what  I can try further.

    Can you also try to access this end point?

    HttpRequest.get("https://global.lianup.com:7777")

    Again, thanks in advance.

    <!– The following comment will be replaced upon deployment with default permissions based on the dependencies of the application.
    Remove the comment if you do not require these default permissions. –>
    <uses-permission android:name=”android.permission.INTERNET” />
    <uses-permission android:name=”android.permission.WRITE_EXTERNAL_STORAGE” />
    <uses-permission android:name=”android.permission.ACCESS_NETWORK_STATE” />
    <uses-permission android:name=”android.permission.ACCESS_FINE_LOCATION” />
    <uses-permission android:name=”android.permission.CAMERA” />
    <uses-permission android:name=”android.permission.RECORD_AUDIO” />
    <uses-permission android:name=”android.permission.ACCESS_FINE_LOCATION” />

    <uses-permission android:name=”android.permission.INTERNET”/>
    <uses-permission android:name=”android.permission.WRITE_EXTERNAL_STORAGE”/>

    <!– The following comment will be replaced upon deployment with default features based on the dependencies of the application.
    Remove the comment if you do not require these default features. –>
    <uses-feature android:name=”android.hardware.camera” android:required=”false” />
    <uses-feature android:name=”android.hardware.camera.autofocus” android:required=”false” />
    <uses-feature android:name=”android.hardware.microphone” android:required=”false” />
    <uses-feature android:glEsVersion=”0x00020000″ android:required=”true” />

    #23632

    Alex
    Felgo Team

    Hi,

    I just tried the example from the docs, just replacing the url with yours and this error on both on Android and iOS as well:

    Error: SSL handshake failed

    I tested with the iOS and Android Live Client. So I assume the issue is indeed located at your server probably.

    Best,
    Alex

Viewing 7 posts - 1 through 7 (of 7 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded