Forums

OverviewFelgo 2 Support (Qt 5) › Can't debug in qtcreator

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #23274

    Peter

    Hi,

    I am trying myself in developing a game. So I want to learn by customizing your OneCard demo.I think the following message I get during starting my game means that I cant debug:

    11:32:58: Debugging starts

    QML debugging is enabled. Only use this in a safe environment.

    QML Debugger: Waiting for connection on port 41857…

    NOTE: you are running a development build in Release Mode.

    Iam using Ubuntu 19.10 and used your 64bit installer. I tried de-activating shadow build but no change.

    My effective qmake call:

    /home/peta/Felgo/Felgo/gcc_64/bin/qmake /home/peta/OneCard/OneCard.pro -spec linux-g++ CONFIG+=debug CONFIG+=qml_debug && /usr/bin/make qmake_all

    #23287

    jrrobles79

    I think you may need to configure your  project to restore the debug, if the project is configured to production.

    check the steps to set a project on production and backtrace, the key files are:

    your_project.pro ,  main.cpp, and config.json

    #23288

    Peter

    I had to delete the makefile. Thought that qtcreator’s “clean” option would do something like that but didn’t. Issue solved

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support