Forums

OverviewFelgo 2 Support (Qt 5) › Can't upload my build for submission to AppStore

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #19107

    Felgo User

    Hi there,

     

    I have a problem for submitting my .ipa to the appstore

    I’m ok with all the certificates and provisioning profiles, it’s for distribution and AppStore

    I tried to build with automaticCode signing and manaul code signing, and nothing works. Did I miss something?

    For info, the app has the Soomla plugin

    Thanks a lot for helping me, I’ve been struggling with this problem since 2 days

     

    I have this message from iTunesConnect

     

    Dear Developer,

    We identified one or more issues with a recent delivery for your app, “NutrissimRomain”. Please correct the following issues, then upload again.

    <b>Invalid Signature</b> – A sealed resource is missing or invalid. The file at path [NutrissimApp.app/NutrissimApp] is not properly signed. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose “Clean All” in Xcode, delete the “build” directory in the Finder, and rebuild your release target. For more information, please consult https://developer.apple.com/library/ios/documentation/Security/Conceptual/CodeSigningGuide/Introduction/Introduction.html

    Best regards,

    The App Store Team

    #19108

    Marcin

    Hi,
    It looks like there is still issues with certificates and profiles/provisioning.
    At least that is what the error suggests.

    1. So you are 100% you have distribution profile and certificate right?
    That you have the valid team assigned to the project in XCode, and QtCreator as well, since it has the option now.
    2. You also built the app in Release mode in QtCreator as in the Felgo docs for publishing.
    3. You also sure you open in  Xcode project from release built(the build which was done in QtCreator).
    4. When you upload your app to AppStore, you tried the manual option and selected manually distribution profile as well?

    5. Are you able to publish some simple app created purely in xcode, using these certificates/profiles etc? This could help to find out if the issue is with certificates or just the code which is generated in QtCreator.

     

    For me, looks like, there is still some mismatch from the certificates/provision point of view.

     

    #19125

    Felgo User

    Hi,

    After 7 days of struggling with this issue, I have discovered that the problem may come from the ‘assets’ folder. When I remove the folder, I can submit the app…

    So the problem would come from my images??? How can I solve this problem? Manuallys signing the images in the assets folder?

     

    #19126

    Alex
    Felgo Team

    Hi,

    Thanks for letting us know. Can you please try the following two things:

    • Open a Terminal window, navigate to your project root folder and type “xattr -cr .” (Source)
    • Use a tool like ImageOptim to strip any unwanted metadata from your image files

    Then delete the build-folder and do a full rebuild please. Looking forward to your answer.

    Best,

    Alex from Felgo

    #19133

    Felgo User

    Yes it works !!!!

    So the problem came from the assets directory…But the message was too general to understand what happened…

     

    Many thanks

    #19134

    Marcin

    Good to know, I would never guess.

    #19139

    Alex
    Felgo Team

    Thanks for letting us know, the error message from Xcode is indeed confusing then.

    Best,

    Alex from Felgo

Viewing 7 posts - 1 through 7 (of 7 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support