Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 2 Support (Qt 5) › Deploying, can you please give a hand ?!

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #20368

    Felgo User

    Hello everyone !

     

    My very first “game” is done, and I would like to send it to a friend. I would like to deploy it as only one .exe, but it contains Spine Animations, will the .png used for animations will “go” in the .exe ? Or will I have to put them alongside ?

    I also tried to follow this tutorial ( https://felgo.com/doc/vplay-deployment/  then http://doc.qt.io/qt-5/windows-deployment.html# ) but I don’t know where to start… I found the windeployqt file ( located at C:\FelgoSDK\5.11.1\msvc2017_64\bin ) but I can’t go further than :

     
    <div class=”pre”>

    cd C:\path\to\Qt
    configure -static <any other options you need>

    </div>
     

    I got this error message :

     

    ‘configure’ n’est pas reconnu en tant que commande interne
    ou externe, un programme exécutable ou un fichier de commandes.

     

    I don’t know what I am doing wrong, I used the same path ( C:\FelgoSDK\5.11.1\msvc2017_64\bin ) but it doesn’t seem to work.

    It would be great to have some help, thank in advance !

    Cédric

    #20371

    Felgo User

    Hello again !

     

    Today I tried something else, which seems more correct to me :  in cmd I typed :

     

    windeployqt C:\Users\cedric\Documents\build-MyGame-V_Play_Desktop_Qt_5_10_1_MinGW-Release\release\MyGame.exe –qmldir C:\Users\cedric\Documents\build-MyGame-V_Play_Desktop_Qt_5_10_1_MinGW-Release\qml

     

    The console showed a lot of messages, like if it was doing something (I assume it worked ?), but then, when I double click on my .exe, I have this error message : “Le point d’entrée de procédure _ZdaPvj est introuvalbe dans la bibliothèque de liens dynamiques C:\FelgoSDK\Felgo\mingw_32\bin\Qt5Gui.dll”, while the mentionned file (Qt5Gui.dll) is in the same folder as my exe. This whole deploying process is very confusing to me, since I have two folders : build-MyGame-V_Play_Desktop_Qt_5_10_1_MinGW-Release and MyGame, I don’t really know on which I have to work to deploy my .exe. Before doing anything, I kept a copy of each of these 2 folders, just in case I have to take a fresh start ! Any help is still welcome ! 🙂
    Thanks a lot !

     

    Regards,

     

    Cédric

    #20403

    Günther
    Felgo Team

    Hi,

    the image assets are copied to you build folder with the DEPLOYMENTFOLDERS setting in your *.pro file. They require to be shipped along with the exe.
    Your QML source code can also be compiled into the exe, to do so, switch to the RESOURCES system in the *.pro configuration. (This is also described in the publishing guide).

    As Felgo applications extend Qt, the app also requires some relevant Qt libraries. To copy these libraries to your build folder with the exe, the windeployqt  scans the QML source code of your project.
    First, you have build your application in release mode with Qt-Creator. Then you use the windeployqt.exe of the used compiler:

    <FelgoSDK>\Felgo\<Your Compiler>\bin\windeployqt.exe --qmldir <directory-of-project-qml-files> <directory-of-app-binary-exe>
    

    Then you should be ready to go. For Windows Desktop, Felgo uses the minGW compiler by default.

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.