Forums

OverviewFelgo 2 Support (Qt 5) › Doodle Jump example errors/bugs

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #19113

    Ali

    Hello, i am a new dev and i am following the official doodle jump tutorial.

    However, i ran into a bug when i tried to implement the controls part.

    The “system” class (for system.desktopPlatform) was not found, and the linearVelocity.x gives a “linearVelocity does not have members” red line. A quick copy paste ignoring the line works, but the red line still annoys me.

    Note: I am sure that the code is placed correctly in the frog’s box collider, and autocomplete does not help with the system class

    Screenshots:

    https://ibb.co/kN5spH
    https://ibb.co/kEbbGx

    Thank you for your time

    #19152

    Alex
    Felgo Team

    Hi Ali,

    thank you for reporting this. The linearVelocity “error” is just a wrong type in autocompletion, you can ignore the warning.

    The system property is a context property of the GameWindow and should be available anywhere in your project. What platform are you using?

    Cheers,
    Alex

Viewing 2 posts - 1 through 2 (of 2 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support