Forums

OverviewFelgo Installation › error: 'VPApplication' file not found

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #16055

    Vishnu

    Hello All,
    I have installed v-play long back on my MAC OS X El Capitan 10.11.6. Today I have updated using Maintain V-play Engine installer tool. I just started creating an empty vplay 2 project. When i just build it.
    The error was : QApplication not found.

    Then I added QT += widgets to pro. file. Then the error was solved.
    But now I see the error: ‘VPApplication’ file not found. Can someone tell me why it is not recognising the vplay libraries? I think there is something wrong with my configuration.  Please view my Configuration Configuration 2

    Moreover, I don’t see the QML folder in the Qtcreator. I cannot see any QML file.

    Here is the complie output:
    21:50:17: Running steps for project tutorial1…

    21:50:17: Configuration unchanged, skipping qmake step.

    21:50:17: Starting: “/usr/bin/make”

    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -c -pipe -stdlib=libc++ -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk -mmacosx-version-min=10.8 -g -std=gnu++11 -Wall -W -fPIC -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../tutorial1 -I. -I../FelgoSDK/5.7/clang_64/lib/QtWidgets.framework/Headers -I../FelgoSDK/5.7/clang_64/lib/QtGui.framework/Headers -I../FelgoSDK/5.7/clang_64/lib/QtCore.framework/Headers -I. -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk/System/Library/Frameworks/OpenGL.framework/Headers -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk/System/Library/Frameworks/AGL.framework/Headers -I../FelgoSDK/5.7/clang_64/mkspecs/macx-clang -F/Users/vishnu/FelgoSDK/5.7/clang_64/lib -o main.o ../tutorial1/main.cpp

    ../tutorial1/main.cpp:2:10: fatal error: ‘VPApplication’ file not found

    #include <VPApplication>

    ^

    1 error generated.

    make: *** [main.o] Error 1

    21:50:18: The process “/usr/bin/make” exited with code 2.

    Error while building/deploying project tutorial1 (kit: Desktop Qt 5.7.1 clang 64bit)

    The kit Desktop Qt 5.7.1 clang 64bit has configuration issues which might be the root cause for this problem.

    When executing step “Make”

    21:50:18: Elapsed time: 00:01.

    #16056

    Alex
    Felgo Team

    Hi Vishnu,

    the latest VPlay version is built with 5.8.0, so please go to the “Projects” tab in QtCreator and change your Kit to a newer one using 5.8.0 (your log output says you have selected 5.7.1).

    Cheers,
    Alex

    #16057

    Günther
    Felgo Team

    Additional Note: We switched to Qt 5.8 with Felgo Update 2.10.0, which allows you to use the full Qt 5.8 feature set also with Felgo projects.

    The old Build Kits using Qt 5.7 thus no longer include the Felgo library – as Alex said, the Qt 5.8 Kits that are installed with the update should be used instead now. You can have a look at our update guide for Felgo 2.10 for a short explanation about the switch to Qt 5.8.

    It’s also possible to remove your existing installation and download the latest installers from our website for a fresh installation of Felgo with Qt 5.8.

    Best,
    Günther

    #16058

    Vishnu

    Thanks for the reply.

    “It’s also possible to remove your existing installation”. May I know whats is the best way to have a clean uninstall. I am actually running out of memory on my mac. It is just 128 GB SSD. I would like to remove everything and make a clean install. Please let me know the best way. Thanks.
    I tried using maintenance tool I am getting this Xcode error click to preview. May I know how to solve this error. Thanks.
    P.S: I just updated the Xcode.

    update: I just uninstalled using Maintenance tool. I am trying to make a clean install. But didn’t understand what to do with that Xcode error. Any clue, please? Thanks

    #16060

    Günther
    Felgo Team

    Hi Vishnu!

    After installing the latest XCode version, please also run XCode at least once and perform all tasks that pop-up after starting the program. XCode will most likely perform some additional configuration or installations and you might need to accept a changed license agreement.

    If you successfully installed the latest XCode and you can run XCode without any other messages popping up, please try the Felgo Installer again.
    Does this help?

    Best,
    Günther

    #16406

    John Croucher

    I am still getting this error after upgrading to 5.9

     

    09:28:25: Running steps for project VPlayTest...
    09:28:25: Configuration unchanged, skipping qmake step.
    09:28:26: Starting: "/usr/bin/make" 
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -c -pipe -stdlib=libc++ -g -std=gnu++11  -arch x86_64 -isysroot /Applications/Dev/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk -mmacosx-version-min=10.10 -Wall -W -fPIC -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../../../VPlayTest -I. -I/Users/user/Qt/5.9/clang_64/lib/QtWidgets.framework/Headers -I/Users/user/Qt/5.9/clang_64/lib/QtGui.framework/Headers -I/Users/user/Qt/5.9/clang_64/lib/QtCore.framework/Headers -I. -I/Applications/Dev/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/System/Library/Frameworks/OpenGL.framework/Headers -I/Applications/Dev/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/System/Library/Frameworks/AGL.framework/Headers -I/Users/user/Qt/5.9/clang_64/mkspecs/macx-clang -F/Users/user/Qt/5.9/clang_64/lib -o main.o ../../../../VPlayTest/main.cpp
    ../../../../VPlayTest/main.cpp:2:10: fatal error: 'VPApplication' file not found
    #include <VPApplication>
             ^
    1 error generated.
    make: *** [main.o] Error 1
    09:28:26: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project VPlayTest (kit: Desktop Qt 5.9.0 clang 64bit)
    When executing step "Make"
    09:28:26: Elapsed time: 00:01.

     

    Will v-play work on 5.9, or does a new version need to be released?

     

    #16407

    John Croucher

    I found Qt Creator in the Felgo SDK. This version will run the apps.

     

    #16408

    Alex
    Felgo Team

    Hi John,

    Qt 5.9 is not yet officially released in its final version. Until the final release, Felgo is still running on Qt 5.8.

    Cheers,
    Alex

Viewing 8 posts - 1 through 8 (of 8 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support