Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 2 Support (Qt 5) › Example project doesn't work

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #22650

    Vladyslav

    This is reproduced on 3 laptops – one of them has Windows 7, others – Windows 10.

    These are the steps I am doing:

    1. Install Felgo latest version for Windows.
    2. Launch Qt Creator and log in with existing account.
    3. Go to ‘Welcome -> Examples’ section.
    4. Launch PropertyCross app.
    5. Search any city, e.g. ‘London’.
    6. Press ‘Go’ button.

    Result: nothing happens – page with listings is not shown, errors in console are absent. The only message in console is  “serialnmea: No serial ports found” and it appears when I launch the app.

     

    Could anyone help me?

    #22670

    Alex
    Felgo Team

    Hi,

    I just tried the example without any issues.

    The serialnmea message is related to the fact that the app makes use of the device GPS sensor, which is not available on Windows, so that can be ignored.

    Did you try the app with the Live Client or did you build/run it from Qt Creator?

    Cheers,
    Alex

    #23301

    Adrian

    I’m having the same problem, which is preventing me from continuing on the Udemy course.

    I’ve tried on my two Manjaro machines.

    If i add some useful code to the .catch part of the HttpRequest.get(url) in the qml/model/Client.qml file:

    .catch(function(err) {
              console.debug(err)
          }

    then the console of the live desktop client spits out:

    GET http://api.nestoria.co.uk/api?country=uk&pretty=1&encoding=json&listing_type=buy&action=search_listings&page=1&place_name=london
    Error: Error transferring https://api.nestoria.co.uk/api?country=uk&pretty=1&encoding=json&listing_type=buy&action=search_listings&page=1&place_name=london – server replied: Not Found

     

    Maybe it’s struggling with the ssl redirection, or some rate-limiting going on?  I’m not sure, but it’s put the brakes on my Udemy course.

    Any help is appreciated.

    #23310

    Adrian

    I managed to build a debug apk and ran this from my device using it’s own mobile data (4g, not wifi) and I still get the same error message.

    #23327

    Alex
    Felgo Team

    Hi,

    it seems that the endbpoint http://api.nestoria.co.uk used in the tutorial is currently offline. That is very unfortunate.

    If it does not go online soon we will see if we can find a replacement. Thank you for noticing.

    Best,
    Alex

    #23334

    Alex
    Felgo Team

    Hi,

    update on the API, it went back online, so the example should work again!

    Cheers,
    Alex

    #23346

    Adrian

    Thanks for replying.

    I just tried it again and get a 404.  It’s never worked for me in the PropertyCross app, even when I do get a response from the api in a browser?

Viewing 7 posts - 1 through 7 (of 7 total)

RSS feed for this thread

You must be logged in to reply to this topic.