Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 3 Support (Qt 5) › Facebook plugin


Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #12123



    I am trying the Facebook plugin example under the free license and I am having the following error at runtime:

    qrc:///qml/main.qml:76: ReferenceError: Facebook is not defined


    I have generated correctly the licenseKey and the appId.





    Felgo Team

    Hi Phil!
    Did you follow the installation instructions for the plugin?  The plugins are not installed by default, it is required to add the with the MaintenanceTool of your installation.






    So I installed Felgo in /opt/FelgoSDK and I run /opt/FelgoSDK/Tools/QtCreator/bin/qtcreator.sh and I get this message when I try in the Facebook plugin example.

    I also tried to install Qt 5.5.1 with the Felgo repository and it can’t find the following code: import VPlayPlugins.facebook 1.0. I tried to modify QML_IMPORT_PATH but it doesn’t work.

    I am coding under Ubuntu Linux.


    Felgo Team

    Hi Phil,

    I will follow up your support request here: Can you please let me know the following:

    1. For which platform are you building your project (Linux Desktop or a mobile device like Android or iOS)?

    2. If a mobile device, can you have a look inside the directory “<Felgo-Root>/5.5/android-xyz/qml/VPlayPlugins/facebook/” and give us a short listing of the included files (if you’re building for iOS please replace the android-xyz with ios).

    Many thanks,




    1) I am building for the Linux Desktop for the moment and then Android and then iOS.


    2) I do have the plugin for the Linux Desktop but I have nothing under the Android directory:


    $ ls /opt/FelgoSDK/5.5/gcc_64/qml/VPlayPlugins/facebook
    FacebookProfile.qml Facebook.qml qmldir


    $ ls /opt/FelgoSDK/5.5/android-xyz/qml/VPlayPlugins/facebook/
    ls: cannot access /opt/FelgoSDK/5.5/android-xyz/qml/VPlayPlugins/facebook/: No such file or directory




    Felgo Team

    Hi Phil,

    I guess you replaced the xyz with your Android architecture, right? So either /opt/FelgoSDK/5.5/android_armv5, /opt/FelgoSDK/5.5/android_armv7 or /opt/FelgoSDK/5.5/android_x86?

    If yes, can you send us the file “components.xml” from the Felgo install root directory to support@felgo.com so that we can have a closer look into that issue? There is no sensitive data stored in the file, it just lists the installed packages’ names.

    Many thanks,




    Hi Phil,

    just to clearify, here is the standard procedure to get plugins working on Linux, which I just tested myself again:

    1. Install Felgo (I installed to ~/FelgoSDK)

    2. Open the MaintenanceTool (in install root, so for me ~/FelgoSDK)

    3. Select “Add or remove components”

    4. Click “Settings”

    5. Click Repositories

    6. Scroll down, select “User defined repositories” and click “Add”

    7. Enter https://sdk.felgo.com/plugins/linux into the “Repository” column and click “OK”

    8. Click “Next”

    9. On the Package Selection Page, expand “Qt” and “Qt 5.5” and check at least one version of Android (either x86, arm_v5 or arm_v7)

    10. Expand the “Felgo Plugins” node and check “Facebook Plugin”

    11. Click next and proceed with the installation.

    Please keep in mind that to deploy to Android, you also need the Android NDK and SDK as described here: http://doc.qt.io/qt-5/androidgs.html

    Best practice to set this up is to follow our guide for Android deployment: http://felgo.com/doc/vplay-deployment/#android-deployment

    If your problem persists, you might also try to re-install Felgo from scratch and follow the steps above.

    Please let us know if you were able to solve your problem.




    • This reply was modified 8 years, 1 month ago by  Lorenz.


    Sorry for the late reply but the update didn’t fix the problem so I will try to reinstall from scratch.



    I just tried to reinstall everything and by using the MaintenanceTool and I still have the following error when I try to run the FacebookSample:

    qrc:///qml/main.qml:76: ReferenceError: Facebook is not defined


    I did try to rebuild the local project but without any success.



    I am trying to include a QML search path explicitly in the .pro file using:

    QML_IMPORT_PATH = /opt/FelgoSDK/5.5/gcc_64/qml/


    And it still doesn’t work.



    Hi Phil,

    in your Felgo installation folder, there should be a file called “components.xml”. Can you post the contents of this file here?

    Your Felgo installation might be corrupted in some way, components.xml will tell us more.
    Did you delete your whole Felgo folder before installing again, or did you use the same Maintenance Tool and folder as before?


    Are you able to build other apps for Android? Can you try loading one of the Felgo Examples and building that for Android?

    If not, did you follow these steps: http://doc.qt.io/qt-5/androidgs.html

    (in particular, did you run

    sudo apt-get install libstdc++6:i386 libgcc1:i386 zlib1g:i386 libncurses5:i386



    Is there the possibility that the Maintenance Tool doesn’t have full write permissions to your Felgo directory?

    Can your try re-running the installation of the plugin with ./MaintenanceTool > log.txt and send us the log file via e-mail?




    • This reply was modified 8 years, 1 month ago by  Lorenz.


    Regarding this problem and in order to help others then I can say the following:

    – The Facebook plugin doesn’t work on the Linux Desktop; only on Android or iPhone

    – I needed to use Qt version 5.5; I was using Qt 5.3


    Now I have a problem with the license but this is out of topic to this thread.  Thanks for the great support.



    Hi Phil,

    Glad you managed to work it out.

    Thanks for the feedback, we will update our documentation!

    Concerning the license-problem, please contact us via e-mail.




    Felgo User

    Hi Lorenz

    I also stuck in the same problem, I have to use Fb, Twitter login on my QML app.

    I am using Qt5.5 and Qt 5.6 with creator 3.6.1 but unable to use Fb login, During this process doesn’t show name of the user.

    Currently using Linux and than will deploy on Android but how can i do that please suggest..

    Project is facebookSample available on git by v-play and just update my app_id with other needed..


    Please revert ASAP…



    Felgo Team


    As we simplified the integration process for plugins, the FacebookSample on GitHub and description in the above thread is no longer valid. There’s no need to install the plugins with the MaintenanceTool anymore. They are installed along with the engine now. Please use the new PluginDemo to see how to use and integrate all of the plugins. You can also have a look at the documentation of the Facebook plugin for a description of the integration steps.

    The Facebook plugin is still only available for iOS and Android, so it is required to deploy to a mobile device to test the features. See our Android Deployment guide or watch the tutorial video to learn how to build and deploy Felgo applications for Android.

    Hope this helps!


Viewing 15 posts - 1 through 15 (of 15 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded