Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Facebook Plugin on iOS 14

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #24332

    Carlos J Yu

    Hi Felgo Team,

    Good Day!

    I’m using Facebook plugin as my login on my app, it stops working on iOS after I updated to:

    <b>Developer Tools:</b>

      Version: 12.5 (12E262)

      Location: /Applications/Xcode.app

      Applications:

      Xcode: 12.5 (18205)

      Instruments: 12.5 (64544.130)

      SDKs:

      iOS:

      14.5: (18E182)

      iOS Simulator:

      14.5: (18E182)

    It works fine on my Android version, I also tried Felgo’s facebook plugin example and the result is the same. Please advise.

     

    Thank you,

    #24334

    Alex
    Felgo Team

    Hi,

    thank you for that report. Can you further describe the issue that you are facing and where it “stops working”? Does the Facebook login dialog appear or does “nothing happen” when calling the login function? Or does the plugin not reflect the logged in state after performing the Facebook login successfully?

    Is there any error message in the log output that may be helpful?

    Any description of the steps to reproduce and what we should be looking out for can help us to investigate this faster.

    Also, did you update your test device to iOS 14.5. or did you update your any of your developer tools on your Mac (or both)? This is not completely clear to me from your message.

    Best,
    Alex

    #24335

    Carlos J Yu

    Hi Alex,

    I just updated my Xcode version to 12.5, sdk version to iOS 14.5 and tried it on different devices with different iOS versions the result is the same.

    I only get session state Session Opening, even though i’ve logged in on Facebook session state does not change and my screen is stuck on Facebook login page without any error message you can check my previous email as your reference.

    Facebook {
            id: fbLogin
            appId: "******"
            readPermissions: [ "public_profile", "email" ]
            publishPermissions: ["publish_actions"]
    
            onSessionStateChanged: {
                if (sessionState === Facebook.SessionOpened) {
                    console.log("SESSION OPENED")
                    fetchUserDetails()
                    console.debug(profile.userId)
                }
                else if (sessionState === Facebook.SessionOpening) {
                    console.debug("Session opening...");
                }
                else if (sessionState === Facebook.SessionClosed) {
                    console.debug("Session closed.");
                }
                else if (sessionState === Facebook.SessionFailed) {
                    console.debug("Session failed.");
                }
                else if (sessionState === Facebook.SessionPermissionDenied) {
                    console.debug("User denied requested permissions.");
                }
            }
        }

     

    Thank you

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded