Forums

OverviewFelgo 2 Support (Qt 5) › Felgo 2.10.0 issue: unable to compile for iOs anymore….

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #15813

    Francois

    Hello,

    trying to compile for iOS, I get this error message :

     

    ld: warning: -headerpad_max_install_names is ignored when used with -bitcode_bundle (Xcode setting ENABLE_BITCODE=YES)

    ld: ‘/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib/arc/libarclite_iphonesimulator.a(arclite.o)’ does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. for architecture x86_64

    clang: error: linker command failed with exit code 1 (use -v to see invocation)

     

    ( same issue using Xcode directly )

     

    Working well on MacOS….

     

    Any idea ?

     

    Thanks for your help.

     

    Best Regards.

     

    F.

    #15816

    Alex
    Felgo Team

    Hi Francois,

    Which version of Xcode are you using right now? Did you clean the project after upgrading to the latest version (i.e. delete the shadow-build directory and run qmake and make from Qt Creator)?

    Thanks,

    Alex

    #15817

    Francois

    Hi Alex,

     

    using Xcode 8.2.1

     

    Yes, I deleted the directory build before.

     

    Best Regards.

     

    F.

    #15820

    Alex
    Felgo Team

    Are you using any Felgo plugins or any other third-party libraries in your project?

    Thanks,

    Alex

    #15822

    Francois

    I am using OneSignal and GoogleAnalytics Felgo Plugins.

    But I already tried to comment them and I got the same issue….

     

     

    #15826

    Alex
    Felgo Team

    Hi Francois,

    One more test:

    Does this also happen when trying to build a new empty Felgo project from our file wizard for iOS?

    If not, can you please download the latest zip from https://github.com/Felgo/PluginDemo and try to build that project for ios on your system?

    Thanks,

    Alex

    #15827

    Francois

    Hello Alex,

     

    Starting a new project using the MasterPage template is working. I can compile without error for iOS.

     

    Trying to compile for iOS the PluginDemo :

     

    ld: warning: -headerpad_max_install_names is ignored when used with -bitcode_bundle (Xcode setting ENABLE_BITCODE=YES)

    ld: warning: object file (/Users/francois/PluginDemo/ios/GoogleMobileAds.framework/GoogleMobileAds(flat-x86_64)) was built for newer iOS version (7.0) than being linked (6.0)

    ld: ‘/Users/francois/PluginDemo/ios/GoogleMobileAds.framework/GoogleMobileAds(flat-x86_64)’ does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. for architecture x86_64

    clang: error: linker command failed with exit code 1 (use -v to see invocation)

     

    I got the same ENABLE_BITCODE error…

     

    Thanks a lot for your help.

     

    Best Regards.

     

    F.

    #15828

    Francois

    Hi Alex,

     

    FYI, I did a fresh install to test, and got the same error…

     

    Best Regards.

     

    F.

    #15853

    Francois

    Hello,

     

    I found a small workaround.

     

    Adding in .pro :

    CONFIG -= bitcode

     

    I can compile again.

     

    Still don’t find where is the problem exactly…

     

    Best Regards.

     

    F.

     

     

     

    #15968

    Günther
    Felgo Team

    Hi Francois!

    We’ve got an update on this:

    The issue actually comes from a bug within Qt, so we have to wait until this is fixed by the Qt guys.
    However, the problem is only relevant when building for iphonesimulator. Deploying to an actual iOS device or archiving the app for publishing in the app store still works as usual. The best solution is to use a real device for testing until the problem is solved.

    The workaround of adding CONFIG -= bitcode when building for the simulator looks like it works in most cases and can safely be used. However, please only use this setting for testing locally on the simulator and make sure to remove it again before building the app for publishing in the app store.

    We hope that the problem will be solved soon in one of the next Qt versions.

    Best,
    Günther

     

Viewing 10 posts - 1 through 10 (of 10 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support