Forums

OverviewFelgo 2 Support (Qt 5) › Felgo 2.15.1 feedback

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18521

    Marcin

    Hi Felgo,
    Have some feedback after upgrade to newest version.
    Background, tested only on Desktop or Android, didn’t touch iOS/Mac yet.
    Linux Mint 18.3 with KDE.

    Felgo Live new issues:
    1. My experience show that, at least Android, app from Google play is really unstable.
    If I start app on Android with Felgo server and leave it running, without reloading, for like 3 minutes or so it just crashes.
    Tried 2-3 apps and all of them crash after a while without any actions from my side.

    2. One of my demo is “broken” after the upgrade.
    Tried cleaning the build directory etc but something is wrong.
    Can’t start it either in Desktop or Android.
    Getting, at the start:

    QQmlComponent: Component is not ready
    /home/marcin/.local/share/Felgo Live Client/WindDemo/qml/Main.qml: No such file or directory

    Don’t know what happened. Tested two different apps and all works fine.
    I think, only in this scenario, I am getting error(similar, this one is not full message): Can't save to file ./, doesn't exists. . Can send later full log, case is it only happens for this app so can be related.
    Any idea how to make it work, apart from reinstalling Felgo again?

    3. Please check if Soomla is included on Android.
    At the Android app start getting:

    VPlay - Live: Warning: Plugin "VPlay.plugins.soomla" disabled: Native frameworks not found

    4. There is warning in Android, at the beginning and few times later:
    Empty filename passed to function
    Not sure if this is crucial or not, happens for all my Android apps which I tested.

    5. When testing my main app getting some weird warning for entity manager.
    I used dynamic entity list with entity manger, after every balloon entity creation getting:

    Felgo Live: EntityManager: a component for this variationType was added before, use it
    EntityManager: found a component to create from entityType Balloon and variationType Default : QQmlComponent(0xbe973c68)
    QCoreApplication::postEvent: Unexpected null receiver
    

    If you need can find some time and take a look at some small example which shows the problem.
    Didn’t see any wrong behavior though.

    Now some good things for Felgo live 🙂
    1. Like the new UI and caching, nice stuff.

    2. There was an error before, which I forgot to report.
    When I start first time live app(Android), and the client is already registered in QtCreator, before with Android app there was crash.
    First time in session so the app had to be “uploaded”, when i triggered the upload/start of app from Android Felgo live there was a crash.
    No problem if I triggered the first session run from the QtCreator.
    Now If I use app, not QtCreator, I still get an error but uploading is continued and, eventually, the app starts.
    So improvement 🙂

    3. The crash with Store{] element on Android is no more, thanks.

    Unfortunately, because of not really stable experience, my main project is not usable for Felgo Live, atm.
    It is great for short/simple prototypes/demos.

    #18527

    Marcin

    Just quick update.
    Warning in point 5 also happen in normal development, not only in Felgo live.

    #18531

    Marcin

    6. Could you please check if content scaling(chose the right image base on device resolution) works well with Felgo live?
    I am using ParallaxScrollingBackground with 3 different images: ./bg.png, +hd/bg.png, +hd2/bg.png.
    Using normal deployment images are nicely selected based on the device resolution.
    With Felgo liver server it is always the same, low resolution image ./bg.png.
    Maybe it’s just me, not sure.

    #18538

    Günther
    Felgo Team

    Hi Marcin,

    thanks for all the feedback, we’ll have a look at the issues!

    Best,
    Günther

    #18575

    Marcin

    Hi Günther,
    Thank you for info.

    Btw
    Have small update to point number 2, missing main Qml file.
    I observed similar behavior.
    Scenario
    1. Have opened my own project, lets call it GameDemo
    2. Felgo live works fine
    3. I click File->recent project-> Open “Felgo ParticleEditor example”
    4. Getting error in live server: "/home/marcin/.local/share/Felgo Live Client/GameDemo/qml/ParticleEditorMain.qml: No such file or directory"

    In this “project switch” example, live server looks for main qml in wrong project.
    Of course ParticleEditorMain.qml file is in not my project but new opened.
    It happens for me very often, not sure if 100% though.
    Maybe one of my old projects matters and you won’t be able to replicate it so easily.

Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support