Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo Installation › V-play latest update error

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #17112

    Scott

    I just updated v-play to the latest version via software update.

    Now when I create a New -Empty V-play 2 project. I try to run it and get the following error: “QApplication file not found #include <QApplication> in my main.cpp.

    Qt Creator 4.4.0

    Based on Qt 5.9.1 (Clang 7.0 (Apple), 64 bit)

    OS X 10.10.5.

    Any idea what’s up?

    #17116

    Marcin

    Hi Scott,
    It looks like you try to build the desktop version, right?
    If yes, did you do the bit which is described on the blog entry for this update.
    Please look for “Important Notice for macOS and Linux Developers” in Update changelog .
    Basically it’s about changing the desktop kit which you use to build the app in Linux and MacOS os.

    Probably the notice about this change should be also visible in QtCreator/Maintenance Tool when updating. Not everybody reads always update change log on the website.

    #17120

    Scott

    Thanks that helped. I’m pretty new to V-play so I was just messing around with it so far. I figured staying up to date wouldn’t really hurt me since I only have some project tutorials saved so far. Yea might be a good idea to have that message in the update. Funny I just read the email sent last night. Thanks for pointing me in the right direction. I’ll definitely be reading the change log from now on.

    So does this mean that the other build “Desktop Qt 5.9.0 clang 64bit” won’t work anymore? Should I just disable it?

    #17121

    Marcin

    Hi Scott.
    I think you can disable the old desktop kit.
    My understanding is that this change is for the better and older way is not going to work, period.
    These kind of changes don’t happen too often.
    The truth is this is the first or second time in like 2 years when there was something like this to do.

    #17123

    Scott

    Cool, thanks for the explanation and the reminder to be checking the change log. I guess we all need a reminder.

    Yea right clicking on the old build kit disabled it. Easy and done.

Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.