Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 2 Support (Qt 5) › Felgo support for Android 4.4.2

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #22592

    Jon-Paul

    Hi,

    I’ve been using Felgo 3.2 and able to deploy an app to my (rubbish) Android 4.4.2 phone. Since I’ve updated to Felgo 3.3 I cannot do this anymore as I get the error: “The minimum API level required by the kit is 21”.

    Looking at the Felgo releases, 3.3 added support for Qt 5.13.2 (3.2 added support for Qt 5.12.3). Looking at Qt’s release history, Qt 5.12 supports Android versions 4.1, 5, 6, 7 and 8 (API level 16). Qt 5.13 supports Android 5.0 and later (API level 21).

    So to me, the problem is my Felgo installation uses Qt 5.13 and so can only be used with Android 5.0. Is it possible to allow the latest Felgo to use Qt 5.12? I’ve ran the maintenance tool but there aren’t any options to add Qt 5.12 for Android. I’ve also pointed the Android NDK to the 19c version but this obviously has nothing to do with the Qt version.

    The fact the Felgo release notes state ‘added support for Qt version…’ implies older versions of Qt could still be used.

    Any help is appreciated!

    #22593

    Jon-Paul

    “The new Qt version 5.13.2 requires an increase of the minimum SDK version to 21. Google requires the target SDK version set to 28 for submission to the Play Store”

    Does this mean Felgo can only be used with Qt 5.13.2 and Android SDK version 21 now? So I’ll have to buy a better phone?

    #22646

    Alex
    Felgo Team
Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.