Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 3 Support (Qt 5) › "File not found" while starting empty project

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #15726


    Qt 5.7.1 Windows 7 MinGW

    When i try to run empty Felgo App project i’m getting error:

    QQmlApplicationEngine failed to load component

    file:///C:/Users/Levolex/qml/Main.qml:-1 File not found


    There is no Main.qml file on this path, but I wonder why the library searches QML-files in my user directory and not in project build directory where they are (and it makes sense). In main.cpp I see only relative path ” vplay.setMainQmlFileName(QStringLiteral(“qml/Main.qml”));” and project settings working directory is set to my project directory which contains “qml” subdir. So everything seems to be ok. What settings I should make to fix this problem?


    Felgo Team


    This error seems a bit strange, the relative path in main.cpp is correct and should use the QML files in the build directory of your project.
    Did you install Felgo to a simple default path like C:\FelgoSDK or somewhere else (e.g. you user directory)? It seems that there are sometimes issues on Windows with long or more complex paths.

    You can also try to reinstall Felgo with our installer and see if a clean reinstall to a simple path can solve the problem.

    If it doesn’t help, you can also choose to add QML files as resources to the binary instead (this is recommend for the final publish build anyways).
    See here to learn more about this: Qt Resource System





    Actually problem occured with installation through the maintananceTool.exe of pure Qt installation into the same directory (c:\Qt\5.7\). After your recommendations I’ve completely removed previous installation and used Felgo installer this time, and the error disappeared. So may be “.”(dot) character in the path was the reason. Thank you.




Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded