Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Game network behind proxy

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8054

    Vlad

    Hi

    I’m developing my game with the system, which is located behind a proxy (Ubuntu 12.04 x64)

    How I can setup proxy setting for using Game network WebStorage etc services?

    usual http_proxy/https_proxy is set up but it still cannot access network

     

    Thanks,

    Vlad

     

    #8060

    Christian
    Felgo Team

    Hi Vlad,

    we are using normal XMLHttpRequests for communication, so the requests should pass through your proxy the same way as you access a website through your browser.

    Do normal XMLHttpRequests work in a sample project for you? What kind of error are you getting when accessing Game Network?

    Cheers, Chris

    #8068

    Vlad

    Hi Chris

     

    I’ve tried stocqt example from Qt 5.3 and it doesnt works either

    I did not found any instructions, how i can learn XMLHttpRequests to send requests via proxy using environment variable

    Do you have any clue about it?

     

    Thanks,

    Vlad

    #8069

    Christian
    Felgo Team

    No I don’t, sorry – please try the qt-project support forums, as this seems to be a general Qt issue.

    Cheers, Chris

    #8092

    Vlad

    Hi Chris

     

    I did some investigations and it seems the best approach is to use
    <h3 class=”fn” style=”color: #363534;”>QNetworkProxyFactory</h3>
    class for set up proxy using system settings and/or environment variables

    But you have to modify your code accordingly

     

    hope this will help

     

    br,

    Vlad

     

    ps. there was similar issue with Qt5 installations/maintenance tool. Now they fixed it since 1.6.3 (afaik). Probably this can be a source for your fix

    #8221

    Vlad

    Hi

    problem solved

    it uses system proxy settings if you’ll add

    QNetworkProxyFactory::setUseSystemConfiguration(true);

    right after

    QApplication app(argc, argv);

    in main()

    • This reply was modified 6 years, 11 months ago by  vladest.
    #8224

    Christian
    Felgo Team

    Thanks for sharing this, Vlad!

    Cheers, Chris

    #8231

    Vlad

    no problems

Viewing 8 posts - 1 through 8 (of 8 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded