Forums

OverviewFelgo 2 Support (Qt 5) › Getting Started with Felgo tutorial not working

Tagged: 

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #9607

    Will

    Hello everyone, I’m new to game development (just recently learned C++) and this looked like a good 2D game engine to start learning in. So, I downloaded the newest version of the engine, and started at the tutorial at (http://felgo.com/doc/vplay-entity-concept/). I got through the first part (Displaying the box on the screen) without any problems, but the next part (Adding the physics) gives an error on the z property; ‘Invalid property name “z”. (M16).’ I looked up the error and a found post on StackExchange saying to put “// @disable-check M16” before the z property, so I did, it got rid of the error, but when I run the game, all it shows is the Felgo splash screen and then a blank white screen; no box, and no falling box. Is there a working fix to this? Or should I switch over to a different engine? I don’t want to struggle against the engine while I’m trying to learn.

    Thanks in advance.

    – TheQuantumBros

    #9608

    Christian
    Felgo Team

    Hi,

    the reason for this is that the gravity already starts to affect the box while the splash screen is displayed. So until it is finished, the box has already fallen down. As soon as you add the ground wall, you will see the box stays on it after the splash finished. We’ll update this tutorial to only start falling after the splash is finished (and will update the z property), thanks for bringing this up!

    If you have any other questions about the tutorials or the sample games, just let us know here in the forums.

    Cheers, Chris

    #9609

    Will

    Christian said:

    the reason for this is that the gravity already starts to affect the box while the splash screen is displayed. So until it is finished, the box has already fallen down. As soon as you add the ground wall, you will see the box stays on it after the splash finished.

     

    That makes sense, once I added the floor the box was visible again. Thank you for your quick helpful response.

    #9772

    Joselmo

    It run ok in debug mode but in normal mode execution it shows the following error:

     

    8276:error:02001015:system library:fopen:Is a directory:.\crypto\bio\bss_file.c:126:fopen(‘e:\repo\openssl_install.9.8zd\vc9\x86/ssl/openssl.cnf’,’rb’)

    8276:error:2006D002:BIO routines:BIO_new_file:system lib:.\crypto\bio\bss_file.c:131:

    8276:error:0E078002:configuration file routines:DEF_LOAD:system lib:.\crypto\conf\conf_def.c:199:

     

    Do you know how I can fix it?

     

    Thank you

     

     

    • This reply was modified 4 years, 3 months ago by  Joselmo.
    #9822

    Alex
    Felgo Team

    Hi,

    which compiler are you using? Do you experience this problem also when creating a Qt-Quick application (without using Felgo)?

    Cheers,
    Alex

    #21900

    Berka Frenfert

    a very simple appPlayground when defines as new item cannot find it no matter what. will i be able to get rid off “Invalid Property name ‘betechItem (M16)’?

    Does Felgo team come from Sencha Touch? They had the same kind of nasty errors. Please let me know what the hell made me stuck on a very simple step.

     

    If it was just to confirm that i am successfully stuck at the right place learning felgo then you guys are too smart for me  🙂

     

    Please let me know what the hell is going on.

     

    betechItem.qml

    import Felgo 3.0
    import QtQuick 2.0
    
    Item {
    
        AppText{
         text: "Betech Item here"
        }
    
    }
    

     

    betechApp.qml

    import Felgo 3.0
    import QtQuick 2.0
    
    
     App {
        id: betechApp
        betechItem{} // here it hangs me up on M16 invalid propert name betechItem
      }

     

    #21901

    Alex
    Felgo Team

    Hi Berka,

    first of all, grab a coffee, calm down and let’s tackle your issue in a meaningful way.

    Can you share your code that causes this issue? (There is a “code” button in the reply box to do this)

    Cheers,
    Alex

    #21902

    Berka Frenfert

    Brother, Thank you for coffee thing and the flying rocket like reply.

    Please let me know if i can export everything and attach with my question. Or may be you need to check again. i edited the question so that you can see the code. I am very new to learning Felgo. Please think of me a dummy and take it easy

    #21903

    Berka Frenfert

    Alex,

    I am following tutorial on udemy. In the video instructor was not stuck on the step i got stuck on. Please let me have url if there is any for a step by step guide. Thank you.

     

    True Regards,

    #21907

    Berka Frenfert

    I have time so i request on this forum to look at my code and at least give me a hint if it is my code the reason for M16 error or is it something else causing the problem. I promise to spend 2 more days just to figure out what went wrong.

    #21912

    Berka Frenfert

    fartonheart@gmail.com said:

    a very simple appPlayground when defines as new item cannot find it no matter what. will i be able to get rid off “Invalid Property name ‘betechItem (M16)’?

    betechItem.qml

    import Felgo 3.0
    import QtQuick 2.0
    
    Item {
    
        AppText{
         text: "Betech Item here"
        }
    
    }
    

     

    betechApp.qml

    import Felgo 3.0
    import QtQuick 2.0
    
    
     App {
        id: betechApp
        betechItem{} // here it hangs me up on M16 invalid propert name betechItem
      }

     

     

    #21915

    Berka Frenfert

    Please let me know how to edit/delete my question/reply ?  The new question or reply does show the edit option but there is no delete option. Actually, i want to delete my old question. How to do that?

    #21920

    Alex
    Felgo Team

    Hi Berka,

    the QML language defines types to start with an uppercase letter, and properties with a lowercase letter. So if you rename your file to BetechItem.qml and use it as BetechItem then it will work fine.

    The error you see is that, as per definition of QML, the compiler treats betechItem as a property of the App component, but the App component does not have a property with such a name –> error.

    I hope that is clear and it could resolve your question.

    Cheers,
    Alex

    #21921

    Berka Frenfert

    Hi Alex,

    it worked now with BetechItem. I continued the tutorial. Thank you.

Viewing 14 posts - 1 through 14 (of 14 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support