Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Google Play Warning: Vulnerable OpenSSL

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #8537

    Preston

    Hi,

     

    I uploaded a app created with V-play a few months ago.

    Now I”m getting a warning from Google Play.

     

    How do I fix this?

     

    This is the warning:

     

    You should update OpenSSL as soon as possible.

    The vulnerabilities were addressed in OpenSSL versions beginning with 1.0.1h, 1.0.0m, and 0.9.8za. To confirm your OpenSSL version, you can do a grep via (“$ unzip -p YourApp.apk | strings | grep “OpenSSL””). For more information about the vulnerability, please consult http://www.openssl.org/news/<wbr />secadv_20140605.txt.

    #8540

    Alex
    Felgo Team

    Hello,

    you can fix this issue by (porting to and) re-compiling your project with the latest Felgo Version 2.3.0, which is based on Qt 5.4 and therefore links against OpenSSL 1.0.1j (Qt versions <= 5.3 incorporate older OpenSSL library versions, therefore being vulnerable as stated by Google).

    Best,

    Alex

Viewing 2 posts - 1 through 2 (of 2 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded