Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Help with WASM build?

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #23525

    Edward

    Hey guys;

    I’m trying to build my app with WASM, following the guide https://felgo.com/doc/felgo-deployment-web/#build-your-project

     

    Everything seems to work fine up until the final step (windows) when trying to run ‘make’, I get the error:

    mingw32-make.exe: *** No targets specified and no makefile found. Stop.

     

    So up until that point I get:

    set PATH=C:\V-PlaySDK\Tools\mingw730_32\bin;%PATH%
    
    C:\V-PlaySDK\Felgo\wasm_32\emsdk\emsdk_env.bat
        //adding directories to PATH: 
        //PATH: += C:\V=PlaySDK\Felgo\wasm_32\emsdk 
        //PATH: += C:\V=PlaySDK\Felgo\wasm_32\emsdk\upstream\emscripten
        //PATH: += C:\V=PlaySDK\Felgo\wasm_32\emsdk\node\12.9.1_64bit\bin 
        //PATH: += C:\V=PlaySDK\Felgo\wasm_32\emsdk\java\8.152_64bit\bin 
        //Setting environment variables …….
    
    
    mkdir build-wasm && cd build-wasm
    
    C:\V-PlaySDK\Felgo\wasm_32\bin\qmake.exe C:\Users\Administrator\Documents\Applications
        //Cannot read C:/Users/Administrator/Documents/Applications: Access is denied. 
        // Error processing project file: C:\Users\Administrator\Documents\Applications
    
    mingw32-make.exe 
        //***No Targets specified and no makefile found. Stop

     

     

    #23526

    Alex
    Felgo Team

    Hi,

    the qmake command needs the path to the actual project, looks like you only added the path to the parent folder where you have all projects. Something like:

    C:\V-PlaySDK\Felgo\wasm_32\bin\qmake.exe C:\Users\Administrator\Documents\Applications\yourprojectfolder

    should work.

    This should then successfully run qmake, which creates a makefile that can then be executed with mingw32-make

    Best,
    Alex

    #23528

    Edward

    Hi Alex,

    Thanks for that!

    After making the changes I was still having issues – until I realised where I use QtAndroidExtras for my app I had to remove this for it to build’\!

     

    Thanks

    Edd

     

     

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded