Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 2 Support (Qt 5) › iOS Landscape woes

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #8480

    Alec

    Hi,

     

    I just got hold of a mac and iPad air to have a quick play with v-play for iOS.

     

    I followed the instructions to get everything set up and it seemed to go well. I then started by trying to deploy one of the templates to the iPad.

     

    It works but doesn’t scale correctly to fill the screen.

     

    I don’t have a flash on my camera so it’s a bit dark but this screen shots shows what happened:

     

    http://imgur.com/BlIKyfw

     

    Even the splash screen is crammed into the bottom left corner. An app with portrait selected as the orientation works fine. Desktop and Android also work fine in either orientation.

     

    Apologies if I’m being stupid here but I can’t figure it out at all.

     

    Can anyone pint me in the right direction? Is there any info I can give that might be useful?

     

    Some details:

    Macbook Air, os x yosemite

    Ipad air, iOS 8

    Xcode version 6.1

    Qt Creator 3.2.2 (open source) Based on Qt 5.3.2 (Clang 5.1 (Apple), 64 bit)

    Changed !host_build:QMAKE_MAC_SDK=macosx10.8 to !host_build:QMAKE_MAC_SDK=macosx10.9 in qdevice.pri

    • This topic was modified 5 years, 11 months ago by  alb.
    #8482

    Alex
    Felgo Team

    Hi,

     

    The landscape mode with iOS 8 is currently not supported with the latest Qt version (5.3) used by Felgo, to fix the issue please download Xcode 5 from developer.apple.com and deploy your game using iOS 7 base SDK (the default one with Xcode 5).

    Please let us know if you could fix the problem.

    The issue with iOS 8 will be fixed with the release of Qt 5.4 in the first weeks of December.

     

    Best,

    Alex

    #8483

    Alec

    Thanks for your quick reply Alex.

    I only borrowed the mac and ipad to see how it all works. I’ll be continuing to develop in Linux so will just wait for 5.4.

    It’s good to know it wasn’t me doing anything wrong.

    Other than that one problem, deploying to an ios device was pretty painless.

     

    Thanks again,

    alb

     

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.