Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 4 Support (Qt 6) › Issue with Camera Usage in Felgo Live on Android

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #25089

    Felgo User

    Hello everyone,

    I am encountering an issue with Felgo Live on my Android device when using the camera in my application and I’m hoping someone here can assist me. I am using Felgo 4 on my development machine and version 2.0 of Felgo Live on my Android device running MIUI Global 14.0.4.

    My application uses a NavigationStack and a camera feature. Here is a snippet of my code:

    import QtQuick
    import Felgo
    import QtMultimedia
    AppPage {
        id: controlPage
        title: qsTr("Control")
        Rectangle {
            anchors.fill: parent
            Camera {
                id: camera
                active: true
            CaptureSession {
                camera: camera
                videoOutput: output
            VideoOutput {
                id: output
                anchors.fill: parent
                fillMode: VideoOutput.PreserveAspectCrop
            Image {
                id: image
                anchors.centerIn: parent
                width: 200
                height: 200
                source: ""
            AppButton {
                text: "Open/Close photo"
                anchors.centerIn: parent
                onClicked: {
                    camera.active =  !camera.active


    This code is used here with navigationStack.push() and navigationStack.pop() :

    Component {
            id: controlComponent
            ControlPage {


    Everything works perfectly when I run it on Felgo Live on my PC. However, when I use Felgo Live on my Android device, I encounter an issue after using navigationStack.pop(). After executing this command, my application becomes unresponsive. I can tap anywhere, but nothing happens. Moreover, I can’t even drag the Felgo Live bubble on the screen.

    I tried to reproduce the issue on another Android device and encountered the same problem. I also checked the console of Felgo Live Server on my development machine, but I saw no error messages.

    I noticed that the issue does not seem to be specific to my application, as even Felgo Live itself seems to be affected (I can’t drag the Felgo Live bubble).

    I tried to search for a solution to this issue online, but I couldn’t find any useful information. I would greatly appreciate any help or suggestions you could provide.

    Thank you in advance for your assistance.



    Felgo Team


    this is probably realted to https://bugreports.qt.io/browse/QTBUG-110868

    We are currently evaluating Qt 6.5.2 for the next Felgo update, and will also verify a better stability of the Qt Multimedia module with this version.

    A potential workaround for now could be to have the Camera related components in the root of your application and only show/hide them on demand, without destroying them (a page on a NavigationStack is created/destroyed on demand). So the camera will then not be part of a sub page, but rather an overlay of the application, which could probably also work for your app design.


Viewing 2 posts - 1 through 2 (of 2 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded