Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 1 Support › Mac os Catalina is blocking Clang++

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #22352

    jrrobles79

    I make the mistake of upgrading my mac os to Catalina, and  now I can’t compile for android, I keep getting the error ‘clang++ cant open because cant verify the developer’, I already did the: sudo spctl –master-disable but is not working, I dont know what else I can do, I was searching a way to fix this , but I haven’t found anything.

    #22368

    jrrobles79

    To answer my question, you can fix this with this procedure… very anoying but it works…

    source:

    https://stackoverflow.com/questions/58390545/cannot-use-old-ndk-android-ndk-r17c-after-catalina-upgrade-due-to-new-security

     

    BTW don’t forget to run:

    sudo spctl --master-disable

     

    Steps:

    1. Go to “System preferences” > “security and privacy”
    2. On “allow apps from:” check  “App Store and identifier developers” not the “anywhere” option. You can select this again after you are done.
    3. Left the window open.
    4. Build your project and when the  “XXXX  cannot be opened because the developer cannot be identifier” error show up go, select “Cancel”
    5. Go to Security and Privacy and the button   “allow” will show up, just click it and repeat the process the times you need…
    6. Once you finish on “Security and Privacy” select “allow”  option again.

    This is the only solution I could find , but if there is another more easy to do, share it please.

Viewing 2 posts - 1 through 2 (of 2 total)

RSS feed for this thread

You must be logged in to reply to this topic.