Tour Preview

Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 2 Support (Qt 5) › Ministro Dependency

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #10596

    Martin

    When I install my application on my Android Phone I get a Message Box stating that I need to install ministro. I thought the apk includes all needed files?

     

    In the build options for the APK i have selected to pack the qt libs into the apk but it seems like this is not working?

    Any hints what could be wrong?

     

    I am building on Windows and for Android armeabi v7a.

    #10599

    Günther
    Felgo Team

    Hi Mailerdaimon,

    Yes, the APK should include all the files you need – there’s no need to install Ministro.

    After you check your settings again to bundle the Qt libraries in the APK,  can you please try this:
    Delete the build-folder and then run the clean and qmake commands (right-click on the project), before you do a new android build?
    This will lead to a completely fresh build, that hopefully correctly packages everything.

    Alternatively, you can also try using the Gradle Build System. Maybe removing the Android Kit from the project and adding it again can also help.

    If nothing of the above works, can you try to deploy a new, empty demo project? Does the problem also occur for this project?

    Best,
    GT

     

     

    • This reply was modified 5 years, 2 months ago by  GT.
    #10641

    Martin

    Hey GT,

     

    thank for your Answer.

    I tried all off what you suggested except creating a new Project and none of it worked so far. Even when using Gradle the App still shows the Ministro message…

    I will check if it works with a new project as soon as I have some spare time.

     

    Again thanks for your help!

     

    Cheers,

    Mailerdaimon

    #10642

    Martin

    Ok, it works now.

    A new empty Project worked without a problem so I checked every setting.

    In my AndroidManifest the Default permissions  and default feature had to be checked then everything worked.

     

    Thanks!

    #10643

    Günther
    Felgo Team

    No problem!
    I’m happy to help 😉

    Best,
    GT

    • This reply was modified 5 years, 2 months ago by  GT.
Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.