Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo Installation › Missing includes Ubuntu 14.04 64-bit

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #10727


    FelgoSamplelauncher.sh does not run.  The LD_LOAD_PATH environment variable doesn’t work as you intended, apparently. I ran strace -eopen and looked at the library search, and it never traversed the contents of LD_LOAD_PATH.  I skipped this and moved on to trying to run one of the demos directly.

    All of the demos fail with missing includes.  QApplication, VPApplication, QQmlApplicationEngine, just depending on which demo.  I haven’t gotten a single one of your .pro files to build.

    I don’t have any spaces in my path.  I installed everything from scratch yesterday, and if the installation is corrupted, your installer is broken.  I checked for updates just now, and there were none.

    I put a lot of effort into this, and I have found this experience severely disappointing.




    Sorry, my bad!

    Unfortunately, in the latest release, not all dependencies were packaged with the samplelauncher.

    We already solved the problem and will release an update for the samplelauncher tomorrow.

    In the meantime, you can download the following zip and extract it to the root folder of your samplelauncher. That should fix the sample launcher at least.



    Regarding the samples not starting, did you already try running

    sudo apt-get install g++ libglu1-mesa-dev

    as described here: http://felgo.com/doc/vplay-installation/#ubuntu-linux

    Best Regards,



    Felgo Team

    Just a short heads up, we just released a new version of our standalone sample launcher which you can download here: http://felgo.com/samples/





    I forgot to come back and let everyone off the hook.


    Your .pro files didn’t build due to the missing -dev package.  I downloaded my own separate Qt and got some old stuff ported to Qt 5 and deployed on the device, so I knew my environment worked fine.  Your .pro files still failed with random missing includes though.  I pulled my hair out for a long time.  I’ve been a Qt guy for 13 years, and this is baby stuff, right?  It should be!


    So I obviously found and installed the missing headers getting my own environment up, but what I never did was try building with your environment after I had supplied the missing headers.  You know, the environment that actually has the Felgo libraries?  Yeah.  That one.  Moron.


    I made it past all that a long time ago, and then the phone rang, and I’ve been on a wild ride for the past few days.  I’ll get this looked at soon.



    So I understand that all problems are sorted out and you can finally give Felgo a go? 🙂

    If you experience any further problems, don’t hesitate to come back to us!



Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded