Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › MYSQL not loaded

Tagged: , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20744

    Daniel Muriithi

    I keep getting this error when running my application

    QSqlDatabase: QMYSQL driver not loaded
    QSqlDatabase: available drivers: QSQLITE QMYSQL QMYSQL3 QPSQL QPSQL7
    QSqlQuery::exec: database not open

    I already have MYSQL server installed on my ubuntu 18.04. What could I be missing?

    #20745

    Alex
    Felgo Team

    Hi Daniel,

    are you using Felgo Live Reloading or standard deployment from Qt Creator? Also this seems to be a Qt specific issue, have you also tried searching the web and/or post the question in the Qt forums?

    Cheers,
    Alex

    #20781

    Daniel Muriithi

    Hi Alex,

    I am using standard deployment from Qt method.  Also I’ve done research and tried to implement everything I’ve found but it still doesn’t work.

    PS: I’m on Ubuntu 18.04.

    Thanks,

    Daniel

    #20787

    Günther
    Felgo Team

    You can find more information on Qt SQL drivers here:
    http://doc.qt.io/qt-5/sql-driver.html

    There are quite some steps involved to build the drivers for different target platforms. As this is a Qt-specific process, I highly suggest to ask for help in the Qt forums. And in case this turns out to be a bug, it should be posted to the Qt bug tracker.

    Best,
    Günther

Viewing 4 posts - 1 through 4 (of 4 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded