Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Navigationstack push dynamic Component dies on Desktop Release

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #23594

    Patrik Dusek

    Hi all,

    I have a very strange behaviour when I push a component on the navstack. It works fine for ios, android (release, and debug) and desktop debug.

    But when I run it on Desktop release the app dies.

        var component = Qt.createComponent("CaseResultPage.qml");
    
        navigationStack.push(component, {currentSection: pageCases.currentSection, arrayChecked:pageCases.arrayChecked})

    Orignally I had it as inline Component:

    
        Component {
            id: caseResultPage
            CaseResultPage {id:casesResultPage}
        }
    ....
    
    navigationStack.push(caseResultPage, {currentSection: currentSection, arrayChecked:arrayChecked})

    As I said it works perfekt on all execpt Desktop-Release. The app just dies with no hints.

    Is there something different in handling push on release mode or in creating components? (only desktop!)

    Thx,

    Patrik

    #23596

    Alex
    Felgo Team

    Hi Patrik,

    I cannot think of any difference that would explain this right away. Is the path to the qml file correct? Are you using deployment folders or resources? Is this macOS Desktop or any other platform?

    If you can extract a minimal example that is able to reproduce the issue, you can send it to support@felgo.com so we can have a closer look.

    Best,
    Alex

    #23599

    Patrik Dusek

    Hi Alex,

    there are so many components, that getting them out for a small example would take hours 🙁

    The path to the qml is fine. I tried it already with additional deployment folder but it makes no difference. As I said it works fine for all other configurations. So it has to be another reason.

    Its on windows.

    BTW: I tried to make then a deploment for debug but windeploy gives me an error for not found plattform plugins.  Any hints?

    Thx,

    Patrik

    #23603

    Patrik Dusek

    Hi Alex,

    found the error. Standard C++Trap 🙁 Had a c++ call which didn’t return a defined value in one case.

    thx,

    Patrik

Viewing 4 posts - 1 through 4 (of 4 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded