Forums

OverviewFelgo Installation › Necessary Android SDK and NDK versions

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #20811

    Andrew

    Hello

    I am begginer in Qt\V-play and mobile development.

    Tell me please, what android sdk, sdk build-tools and ndk versions and extra settings in Qt Creator is needed for the latest V-play?

    I can create new project in Android Studio (latest version) then deploy it on my Android device whith no problem, but when I create new V-play App project and then try to deploy it I get a build error “No toolchains found in the NDK toolchains folder for ABI with prefix: mips64el-linux-android”.

    With the same configuration (API 26, SDK 26.1.1, NDK 10-16) I can open and deploy some V-play demo apps (e.g. Component Showcase, PropertyCross, Weather) but can’t deploy other demo apps (e.g. Multi-Scene-Multi-Level, Flappy Bird, BalloonPop) and any new project.

    I tried SDK 26\25, NDK 10\12\14\16 and get the same result.

    Thanks.

     

     

     

     

    #20817

    Alex

    I got the same error..

    #20818

    Günther
    Felgo Team

    Hi,

    this issue stems from some Android tooling changes of recent versions:

    The NDK removed support for mips abi. But earlier versions of the android gradle plugin still check for the existence of the mips toolchain.
    see here for more info.

    Many demos and Felgo projects come with a certain android/build.gradle configuration. You can find the build.gradle file in the android folder of your Felgo project. As some projects do not have a specific build.gradle configuration, the latest gradle plugin is used, so these projects work without issues.

    We did not yet update all demos and build.gradle settings for this change. Also, certain Felgo Plugin library dependencies require to still use an earlier gradle version for compatibility reasons.

    As a workaround, you can manually add the missing toolchains to your Android NDK. You can find a guide here:
    https://medium.com/@ivancse.58/how-to-resolve-no-toolchains-found-in-the-ndk-toolchains-folder-for-abi-with-prefix-b37086380193
    Best,
    Günther

    #21439

    Paolo Mazzon

    Unfortunately this framework is too cumbersome. Every time you always have to put something in place, the guide is not updated and every time on the forum I have to wait 24 hours, I first program in Android studio sin because the idea is good.

    #21442

    Günther
    Felgo Team

    Hi Paolo,

    this error stems from a general issue for all Android App Projects. The Android NDK suddenly dropped support for the mips architecture, which is expected by some Gradle versions.

     

    One simple solution is to modify the project’s build.gradle to use

     classpath "com.android.tools.build:gradle:3.2.0"
    

    However, we did not yet test all demos, examples and Felgo plugins for this version yet. We thus recommend to use NDK 14, which is not affected by this issue. To run the projects with their specified Gradle version with a later NDK version, the mentioned workaround is required.

     

    We are working on updating to Qt 5.12.2 with support for latest NDK versions at the moment. We are sorry for the inconvenience!

    Best,
    Günther from Felgo

    #21485

    Paolo Mazzon

    I think I have solved you have to put the shorter step of the example build:

    c:\app

Viewing 6 posts - 1 through 6 (of 6 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support